So I installed Lubuntu 16.04.2 a couple of days ago on an older laptop and I'm very satisfied with the performance now compared to Windows 7 which was uselessly slow. It runs well and stable but I think auto updates are broken..

The update notifier showed up on the first boot but not anymore, I have not changed any update settings in the GUI tool. Only ran apt-get unattended-upgrades then edited the config file to enable the -updates and -backports sources lines plus auto reboot false. It's been a couple of days now, it's been powered off during night time and not running all days either but the Update Notifier never showed again on login and no updates have been installed after setup. (There are currently about 70MB updates available with apt-get upgrade)

I have only removed firefox plus its locale packages then installed pavucontrol and chromium-browser. I did notice that drop down option with download and install security updates automatically in the update manager got greyed out and could not be changed somewhere along the way.. Installing unattended-upgrades made it selectable again in the GUI, this tipped me off something may have gone wrong and the only thing removed was firefox on this system.

But, when removing firefox it also removed ubuntu-desktop, maybe that's the culprit? Also seems whatever changes where made can not be restored either, as now when running apt-get install ubuntu-desktop it wants to install 1.5GB which would add a lot more stuff than what was included from the beginning. So my guess is that because Lubuntu is trimmed down a lot the ubuntu-desktop parts are maybe customized in a way that removing it breaks automatic updates and even prevents the update notifier to show up, is this possible or likely?

Maybe ubuntu-desktop (and firefox) must be left installed for it to work, which brings me to my next question. Can firefox be removed without it taking down ubuntu-desktop with it? Also can updates be disabled for only firefox if it's left installed? Because there's only mobile internet used in this case it would be better if updates use up less of those limited megabytes, as only chromium is used anyway. That's another reason I want to run Lubuntu here because the downloads should be smaller than other Ubuntu flavors. I'm now thinking of reinstalling the whole thing and just leave firefox installed next time.

I'm definitely not going back to Windows anytime soon but if auto updating is not reliable for some reason and can not be fixed it's a big shame :( This is not my laptop either I won't be around to update it regularly at all and updates will never be installed manually...

I've searched around and have not found a definite answer but I see others are experiencing problems with this function without getting it to work in the end. I've used many hours now trying to find out how to set this up properly and follow guides, but I don't really have much skill to dig into this deeper myself. It seems to work for the full Ubuntu so that's still an option I guess. Anyway I thought I'd leave my experience here at least maybe it can help!


Maybe I messed something up when I was testing some stuff before and also tried a bunch of different methods to do auto updates.. So yesterday I did a new clean install of Lubuntu and never even started the GUI update manager then turned off the laptop. Today I started it up to do some web browsing and after a while maybe half an hour I noticed the hard drive started working, I checked the process monitor and it was updating! Did not get any notifications and when it was done it did not ask for reboot so everything went completely seamless in the background. Then I ran apt-get upgrade just to check and indeed all updates have been installed. FYI my full .bash_history file has these commands:

sudo apt-get purge firefox
sudo apt-get purge firefox-locale-en
sudo apt-get purge firefox-locale-sv
sudo apt-get install pavucontrol
sudo apt-get install chromium-browser
sudo apt-get install unattended-upgrades
sudo nano /etc/apt/apt.conf.d/50unattended-upgrades
echo gtk-recent-files-max-age=0 >> ~/.gtkrc-2.0

So after all it now seems to work well even with firefox and ubuntu-desktop removed. I also like that it was delayed a while after booting up and guess this is intentional :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.