4

A few months ago it started the first time when I was listening to music using my headphones: The sound started to be noisily blurred, sounding like an old broken radio with bad connection.

I blamed the headphones but it came up a few days later again. After switching to regular speakers it gave me the very same result. Strangely metallic blurred sound.

Doing some research didn't bring any useful result but I assumed it might be a software-issue as I assume it's a different thing if I output my sounds via the jack or the speakers. Also as a new HD was planned to purchase this problem should disappear by itself when I install a new Ubuntu (Mate).

Right now it just came up again. I checked dmesg but there was nothing of relevance. I played some other music using a different player to see whether or not the issue will persist. Two minutes after going on with that noise everything is went to normal.

What could that be?

pactl list and pactl list both give reasonable outputs (if it helps I can add thatinformation)

8

I have tried to find the solution to the same problem, and for me it happens when firefox is open (sometimes), and closing Firefox solves the problem temporarily.

I wish I had more concrete info than this, but it might help someone else temporarily too, until a permanent fix is found.

More info: pulseaudio -k is another way to solve the problem temporarily, it will most likely stop videos played in browsers and the such so that refresh will be necessary. For some setups it might be a better solution than closing down the whole browser.

Working solution: (Edit: changed this to working solution as it has been over a week with no recurrence of this problem on 3 different machines)

Stumbled upon another answer.

In this case (As my system is of a higher version) we change

load-module module-udev-detect to load-module module-udev-detect tsched=0

in the file /etc/pulse/default.pa and then restart pulseaudio or our system. This has been working for about 3 days so far (From having the problem many times per days).

Documentation on tsched setting :

Since 0.9.11. Use system-timer based model (aka glitch-free). Defaults to 1 (enabled). If your hardware does not return accurate timing information (e.g. Creative sound cards) you can try to set tsched=0 to enable the interupt based timing which was used in 0.9.10 and before.

  • Funny you mention it. The last occurrences were when I talked to a friend using Google Talk and also when I was quickly switching between two videos. As I keep FF open most of the time I will pay attention what's going to happen as the issue reoccurs. Thank you for the input – Qohelet Apr 4 '17 at 11:38
  • Seems by closing and re-opening firefox you can really solve it – Qohelet Apr 17 '17 at 14:55
  • Next time I'll try the other fix you suggested – Qohelet Apr 18 '17 at 9:30
  • Yes, please do! I'm still without problem here after that change. – Karlsson Apr 18 '17 at 15:07
  • 1
    For those who don't get any sound after 'pulseaudio -k', you need to restart the daemon afterwards. So in terminal do: $ pulseaudio -k; pulseaudio -D – Calleniah Mar 17 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.