2

I can see following in the syslog (on ubuntu 16.04)

Mar 28 22:51:36 gitserv systemd[1]: apt-daily.timer: Adding 5h 9min    12.773843s random time.
Mar 28 22:51:36 gitserv systemd[1]: snapd.refresh.timer: Adding 3h 24min 34.415866s random time.
Mar 28 22:51:41 gitserv systemd[1]: Time has been changed
Mar 28 22:51:41 gitserv systemd[1304]: Time has been changed

I have disabled both snapd.refresher.service and apt-daily.service

● apt-daily.service - Daily apt activities
 Loaded: loaded (/lib/systemd/system/apt-daily.service; static; vendor preset: enabled)
 Active: inactive (dead)
 Docs: man:apt(8)


● snapd.refresh.service - Automatically refresh installed snaps
Loaded: loaded (/lib/systemd/system/snapd.refresh.service; static; vendor preset: enabled)
Active: inactive (dead)
Docs: man:snap(1)

I have disabled the NTP sync as well, but this continues to appear at 2-3 second intervals.

Your help is much appreciated, thanks in advance.

  • 1
    unix.stackexchange.com/questions/166639/… may be helpful – Mark Stosberg Mar 28 '17 at 18:31
  • 1
    Thanks for the response @Mark Stosberg, above solution points to disable logging to avoid the log entry. but it looks like apt-daily service and snapd are resetting the time set by each other, which might be the root cause. So how can I address that issue ? Thanks – Harsha Amarasiri Mar 29 '17 at 3:48
1

This worked for me. Not sure if you are running your server on a Hyper-V VM though. /var/log/syslog 'systemd[1]: Time has been changed' message every 5 seconds

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.