2

I recently received a warning message from my Ubuntu 16.04.2 VM on Hyper-V that 99% of my disk is full. Upon further inspection I noticed that my /var/ directory was using over 108G of space and that the 108G could attributed to only four files:

  • 32G /var/log/kern.log
  • 41G /var/log/kern.log.1 (deleted)
  • 11G /var/log/syslog
  • 22G /var/log/syslog.1 (deleted)

I did some polling and noticed that the below line was being logged over 2000 times a second in kern.log (I didn't poll syslog but the same message is logged there)

  • Mar 27 22:08:28 VM-Ubuntu kernel: [ 2830.661832] hv_utils: Using TimeSync version 4.0

How can I stop hv_utils from hogging all the memory on my vm?? Any help would be appreciated...

Cheers, -Sam

  • I just ran into the same problem and ran across this thread after a google search. Worked like a charm. Thanks! – Ryan May 23 '17 at 2:58
1

The fix is relatively easy. Edit settings of the desired virtual machine. Go to Integration Services and disable "Time Synchronization"

  • Thank you this has seemed to stop the nonsensical logging!! – Sam Apr 4 '17 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.