I am seeing the below message during boot, preventing my system from running:

** 19 printk messages dropped **
[200.119021] nouveau <missing> fifo: sched_error 20[<missing>]

How can I fix this?

  • 1
    I've tried to edit this question to what I think the error should say, but I may be wrong. Please edit the question yourself to include the exact error you're getting such that we don't have to guess. – Kaz Wolfe Mar 28 '17 at 5:43

Upon boot, add nouveau.modeset=0 to the command-line arguments. Do this like so:

  1. When booting your computer, hold down SHIFT to get a GRUB menu.
  2. Navigate to the Ubuntu option and hit F3.
  3. Move your cursor to the linux line, after quiet splash.
  4. Type in nouveau.modeset=0, and then hit F10.

When you've booted into your computer, you're going to have to either install the NVIDIA drivers or update your boot config to not allow this error to happen further:

  1. Open a terminal with Ctrl+Alt+T.
  2. Type in the following command, exactly as it appears below:

    sudo nano /etc/default/grub
  3. You will be prompted with something that looks like [sudo] password for user:. Type in your password. You will not see any characters, but rest assured that your password is being typed. Press ENTER when done.

  4. Go to this line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"  

    Edit it to look like:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"
  5. Press Ctrl+X, followed by the Y key, followed by the ENTER key to save your changes.

  6. Run the exact command below to update your bootloader config:

    sudo update-grub
  7. Reboot to confirm that everything is working properly.

| improve this answer | |
  • Thanks bro but i resolved the issue it was showing that error because nividia driver package was not installed . – AMIT DS GUPTA Mar 28 '17 at 9:23
  • I am experiencing the same error but it is not showing on boot, it shows when I come back from sleep although I have installed the NVIDIA drivers. When I opened the grub file it had nouveau.runmp=0 replacing this with the one mentioned in the answer solved my problem – Sami Jun 11 '18 at 22:03
  • Wish I could up-vote the accepted answer a gazillion times. Fixed the issue for me. I'm running a Clevo P640RE. I also added this to my kernel params: acpi_osi='!Windows 2015' - this stopped the random freezing/lock-ups on my laptop. – Vanessa Deagan Jun 25 '18 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.