1

I once ran thunderbird with the sudo command and now when I run it (with or without sudo) it does not load my default profile. The files of my default profile are still in the .thunderbird directory.

2

You likely messed the permissions of the folders that is uses such as the cache, and it's configuration settings.

Try running the following to get back ownership of all files in your home directory, provided you are logged in as the user who cannot open Thunderbird:

sudo chown -R $USER: ~

Make sure you're in your home directory when you do this!

If you are running as another user in a multi-user environment, you must replace $USER with the user's name.

Ensure in the future that you do not run it as root again. Similar issues can happen with other software as well. It is safer to use sudo with the -H flag : sudo -H (executable) so that the software runs in root's home directory instead of your own user's home folder.

  • I fixed your chown command. – Byte Commander Mar 27 '17 at 19:09
  • @ByteCommander Re-edited. That's fine if you only have one user, but not in a multi-user environment where you're fixing another account's permissions. It's always best for one-liner fixes to explicitly specify the username instead of relying on variables. – Dorian Mar 27 '17 at 19:16
  • 1
    Okay, the question did not give me any reason to think that he might want to run that from a second account, but additional clarification can never hurt. – Byte Commander Mar 27 '17 at 19:21
  • 1
    Agreed @ByteCommander. I try to never assume these things, mostly because I administer a large organisation :) In fact, I would probably set the owner in a script by cycling through each /home folder and check the owner with ls -ld ./ | awk '{print $3}' and use that to chown back to the user, but I don't want to go too crazy with my answer :) – Dorian Mar 27 '17 at 19:26
  • Didn't work. I don't know how to use the -p option with thunderbid exactly. – Reza Mar 27 '17 at 19:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.