1

Using Ubuntu 14.04 LTS, I often search from the Mozilla Firefox (52) browser bar.

My default search engine is set to Google, but I find that the first search in a tab always goes to google.com. I want it to go to my local country google site, as this would probably be faster.

I have looked at the Firefox about:config search elements, but cannot see where this direction to google.com is occurring.

Can anyone assist with how to set google to default always to my local country google site?

Edit: Does the DNS service have anything to do with this? Is the DNS being told to go to google.com first, or not?

Edit2: On further investigation, there is xml in files like "/usr/lib/firefox/distribution/searchplugins/locale/en-GB/google.xml" which appear to control search engine urls used. However, even editing these to refer to the local country google site in all cases does not resolve. I am coming to the conclusion that there may be some hard-coding in Firefox itself that is the controlling factor.

2

I can't give you an exact answer for your specific country as it's not in your profile. Be that as it may, Simply point firefox to https://addons.mozilla.org/en-US/firefox/search/?atype=4 and search for google.countrycode where country code is your country code such as google.fr for france or google.de for Google Deutschland. This will add that specific search engine to your available engines by clicking the Add to Firefox button. and allow you to choose it as default by checking the box and clicking Add. See below:

google.de

  • This seems to only apply to a limited set of countries, and does not include the one I want. – Joe Mar 27 '17 at 18:37
  • @Joe I'm sorry to hear that. Your question doesn't specify what your local country is and sadly we are all unable to guess. Please review askubuntu.com/questions/ask – Elder Geek Mar 27 '17 at 18:46
0

One method is to delete all the cookies from google.com in Privacy tab. But if this method does not work go to about:config and change the values in following preference settings accordingly.

browser.search.countryCode
browser.search.isUS
browser.search.region
  • No cookies set due to "Never remember history". Browser search values were already set as relevant. – Joe Mar 27 '17 at 18:38
  • Changing value of browser.search.countryCode and browser.search.region will do the job. – arupgsh Mar 28 '17 at 4:14
  • Thank you for your answer....but these values are already set to the local country code. Also, "isUS" is set to false. – Joe Mar 28 '17 at 9:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.