0

My alsa info: http://www.alsa-project.org/db/?f=f940e25a16fa01f2a1c2f980562b2a97d4b97ee5 My k56cd asus laptop has a combo jack (both headphones and mic) so when i plug in my headphones (Razer Kraken pro neon which have only 1 jack) only the headphones work, the mic does not.

  • Check sound settings and make sure your microphone isn't mute. – Dante Mar 27 '17 at 16:24
1

You could verify also with alsamixer. Open the terminal and type alsamixer and then look for the microphone settings in alsamixer.

0

The problem could be that the input devices are not set up correctly. You should try PulseAudio Volume Control to correctly set it up.

sudo apt-get install pavucontrol

Open it up:

pavucontrol

Go into the Input Devices tab and underneath your audio card select the correct mic from the drop down list.

However, if your issue occurs when you reboot with the jack still plugged in, it can sometimes be resolved by simply unplugging and plugging the jack back in once the computer fully starts back up.

0
  • Install hda retask with:
    sudo apt install alsa-tools-gui
  • Open hda Retask with the windows key or in terminal:
    hda-jack-retask
  • Select in the up-right menu "Show unconnected pins"

  • In the not connected pins 0x18 and 0x19, select "override", and select "microphone". If, they don't have the microphone option, do this in 0x16 or 0x12

  • Click "apply now" (bottom right) and "install boot override".

  • Open pavucontrol, go to Input devices and select Microphone (if it appears unplugged see if the volume indicator moves while you speak, otherwise restart).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.