9

when i do ctrl+c or hit menu => copy, Nautilus freezes on several seconds.

This doesnt happen on paste.

If i open nautilus on console, no related error is shown. I tried upgrading from 16.10 to 17.04 and even added experimental PPA, but nothing fixed it.

Did anyone observe this? Thanks.

  • system lags sometimes could be due to memory size available. Try to monitor the memory status when you are performing the same task. You can also use cp -r [source] [destination] to copy files in the console. use -r flag if it includes directories/folders – saviour123 Mar 27 '17 at 10:42
  • 1
    That is probably not the case, since i am not copying anything. The ctrl-c action itself freezes nautilus. – Aiphee Mar 27 '17 at 10:45
  • Copying with nothing selected can cause delays. Also with gedit editing file name that doesn't exist causes pauses. – WinEunuuchs2Unix Mar 27 '17 at 14:52
  • Well it aint normal if hitting ctrl+c causes Nautilus to freeze for several seconds. – Aiphee Mar 28 '17 at 8:30
  • Facing the same issue. First I thought I messed up something but same is happening even after installing 17.04. And I have 16 GB RAM so I have plenty memory available. – Pavak Paul Apr 24 '17 at 13:52
7

Rename 'kdeconnect-cli'

I think this problem is facing by who installed KDE Connect on their system. I have Ubuntu 16.04 and I was also facing same problem with nautilus-3.20.3 while ctrl+c or right-click => copy. I analyzed system monitor, /var/log/syslog and found that when we press ctrl+c, a process name 'kdeconnect-cli' appear in system monitor.

So I renamed this file like '__kdeconnect-cli' in the directory /usr/bin and the problem solved but now I am not able to send files to my Android device with right-click.

'kdeconnect-cli' is a KDE Connect CLI tool that is responsible for sending files with right-click to your Android device using KDE Connect tool, I guess.

Now you have to use kdeconnect-indicator icon in your status bar to send files to your Android. kdeconnect-indicator

  • The problem disappeared for me some time ago, but your fix would most probably work for me too. This will surely help someone else, thank you. Anyway, in Ubuntu 17.10, the problem seems to be fixed. – Aiphee Jun 29 '17 at 18:12
  • Right on!!! The problem disappeared in Ubuntu 17.10 until I installed the Gnome Shell Extencion called "MConnect", then the problem came back. I use kdeconnect-cli from the command line so I didn't want to mess with it. What I did was delete the Nautilus Python extensions that enable the 'Send To Mobile Device' context menu. They are located in /home/$USER/.local/share/nautilus-python and are called nautilus-send-mconnect. After that, no more freezes or lockups! – SuperMau Nov 15 '17 at 22:06
  • @SuperMau your trick didn't work for me – QkiZ Jan 7 '18 at 21:30
  • @kanha.vishva this trick works but if I rename kdeconnect-cli to something else MConnect extension will don't start. – QkiZ Jan 8 '18 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.