0

I am new to Ubuntu and I am currently running it on Oracle VM VirtualBox in order to work with a software called Xmipp (more details about the software on http://xmipp.cnb.csic.es/twiki/bin/view/Xmipp/WebHome).

Now, I followed the HowToInstall guide, which first requires me to download the Linux Binaries(Ubuntu) from this link. And then, as mentioned on the HowToInstall link, I chose

Option 1:Using Precompiled Binaries

and executed the install_binaries.sh script. I then go the following message:

> #!/bin/bash ID=$$ cat .xmipp.bashrc |grep XMIPP_HOME= |cut -d "=" -f 1 |sed -e "s/XMIPP_HOME/XMIPP_HOME=$(pwd | sed -e 's/\//\\\//g')/g" >
> /tmp/xmipp_binary_creating_${ID} && cat $(pwd)/.xmipp.bashrc |egrep -v
> ".xmipp.cfg|XMIPP_HOME=|^#" >> /tmp/xmipp_binary_creating_${ID} &&
> echo "test -s $(pwd)/.xmipp.cfg && . $(pwd)/.xmipp.cfg || true" >>
> /tmp/xmipp_binary_creating_${ID} && mv
> /tmp/xmipp_binary_creating_${ID} $(pwd)/.xmipp.bashrc && source
> $(pwd)/.xmipp.bashrc && echo 'Xmipp3.0 binaries have been succesfully
> installed in your system. Please, put a source to .xmipp.bashrc file
> in your .bashrc file. Just for this session, .xmipp.bashrc has been
> already sourced, so if you executed the install_binaries.sh script
> with source or . changes will be applied to this shell and so, you
> should be able to execute xmipp from this terminal. If you did it with
> ./install_binaries.sh its time to source .xmipp.bashrc manually to
> have xmipp working in this shell session.'

Since the message says that Xmipp 3.0 Binaries are installed, I then went on to this link and followed the instructions mentioned under

Running library tests (optional but recommended)

Now this is the part where I am finding it difficult to follow the instructions because the authors mention that

you can run the tests by executing (from inside Xmipp home directory) the command:

xcompile gtest=yes run_tests

Now I downloaded Xmipp 3.0 as a file with the following name Xmipp-3.1-linuxbin-all-x86_64.tar.gz and extracted it to my desktop. Therefore, I went to the terminal and wrote

cd ~/Desktop/xcompile gtest=yes run_tests

But then I go at error saying bash: cd: /home/shrey/Desktop/xcompile: No such file or directory. Could please explain what am I doing wrong and how can I make Xmipp work on Ubuntu.

  • 1
    “I then go the following message” This looks just like the script being displayed (instead of executed). How did you execute it? “Please, put a source to .xmipp.bashrc file in your .bashrc file.” Have you done it? (Do you understand what they are asking you to do?) – Melebius Mar 27 '17 at 8:56
  • @Melebius Thank you for your comment. I did not do that and I do not understand what they are asking me to do. – model_checker Mar 27 '17 at 8:58
  • @Melebius could you please help me! – model_checker Mar 28 '17 at 13:42
  • I tried to download Xmipp and the download page says: “Xmipp is now integrated into Scipion. We recommend that you install Scipion and run Xmipp inside it.” Have you tried to follow the answer you got? What was the result? Let the answerer know by accepting the answer or writing a comment to the answer. – Melebius Mar 29 '17 at 11:24
1

The last version of Xmipp has been released under a more general framework, Scipion (www.scipion.cnb.csic.es), which allows you to combine several EM packages (such as Xmipp, Spider, Relion, Eman2, etc) in your project. So we strongly recommend you to install the lastest version of Xmipp 3 through Scipion. In the following link you can find detailed instructions for the installation process:

https://github.com/I2PC/scipion/wiki/How-to-Install

Some tutorials can be found at:

https://github.com/I2PC/scipion/wiki

Hope this helps, Jose Miguel

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.