4

After I upgraded to Ubuntu Gnome 16.10, typing in Nautilus no longer searches through the folder structure recursively, but rather just skips to a file in the folder (the old "type-ahead" mechanism).

Why is this? Is the Ubuntu version of Nautilus patched to do this? How can I enable the standard Nautilus search behavior?

NOTE: This question is the opposite of Traditional search-as-you-type on newer Nautilus versions -- I'm trying to enable global search, disable local search.

0
3

I feel the same way about recursive search so here is a fix for newer versions of Ubuntu:

gsettings set org.gnome.nautilus.preferences enable-interactive-search false

Nautilus should immediately show a change in behavior.

Please let me know if this doesn't work for you, thanks!

3
  • After upgrading to a new version, global search was re-enabled, so now I can't test it out. Thanks for the tip, though. – Tin Man Apr 27 '17 at 7:19
  • Does not work on ubuntu 17.04 for me – RobAu Jul 17 '17 at 6:34
  • @RobAu I don't know. It works for me on 17.04 using nautilus on unity7. Maybe you want the other behavior? Did you try setting this to true instead of false? – mchid Jul 22 '17 at 15:30
2

Open a Nautilus window, then go to Preferences. Go to Search & Preview tab and make sure "search in subfolders" is set to local computer, or all locations, as you need.

1
  • 1
    It is set to "search in subfolders". Doesn't effect anything. – Tin Man Apr 7 '17 at 17:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.