I'm new to Ubuntu. I have bought a new usb wifi adapter (LB-Link- WN155A) and I need to install the driver from CD that came with it, but I can't find any executable files.

I tried How to install linux driver for a lb-link wireless usb adapter but this did not help.

I uploaded the contents of the CD to Google Drive

the result of lsusb enter image description here

the result of uname -r 3.19.0-74-generic

  • The files you have are circa-2013 and it is doubtful that they will compile properly on any recent Ubuntu version. Please edit your question to add the result of: lsusb and also: uname -r Welcome to Ask Ubuntu. – chili555 Mar 27 '17 at 12:26
  • Thanks (@chili555) i will edit my qeustion but please tell me how to compile these files i tried alot but no success – gems Mar 28 '17 at 2:44

I will outline the usual process to compile the files. This may or may not compile on your 3.19-xx kernel. If not, post the errors and I will propose another solution.

First, remove the device. Next, in the terminal, with a temporary internet connection by ethernet, tethered or whatever means possible:

sudo apt-get update && sudo apt-get -y upgrade
sudo apt-get install linux-headers-generic build-essential

Next, navigate to the location of the Makefile; in my case:

cd ~/Downloads/DPA_MT7601U_LinuxAP_3.0.0.1_20130802/DPA_MT7601U_LinuxAP_3.0.0.1_20130802

Now let's try a trial compilation:


If there are errors, please post them here and we'll attempt to fix them. If there are no errors (warnings may be OK), then install:

sudo make install

Insert the device. Is your wireless now working?

EDIT: Since we know now that the driver files included with your device will not compile in kernel version 3.19-xx, please try:

sudo apt-get install git
git clone https://github.com/art567/mt7601usta.git
cd mt7601/src
sudo make install
sudo mkdir -p /etc/Wireless/RT2870STA/
sudo cp RT2870STA.dat /etc/Wireless/RT2870STA/
sudo modprobe mt7601Usta

Please post any errors as before.

You have compiled the driver for your current kernel version only. When Update Manager offers a later kernel version, known as linux-image, after the requested reboot, recompile:

cd mt7601/src
make clean
sudo make install
sudo modprobe mt7601Usta

Please retain the file and these instructions for that time.

  • when i execute make command i faced the following problem drive.google.com/open?id=0B-JmvL9zDs3JRXRBZ1RuR29PWmM – gems Mar 28 '17 at 16:20
  • That's what we call at our house, a trainwreck. You were warned earlier that, "...it is doubtful that they will compile properly on any recent Ubuntu version." I shall edit my answer to propose a better solution. – chili555 Mar 28 '17 at 20:06
  • thanks alot @chili555 that worked for me......you're great – gems Mar 29 '17 at 4:41
  • Please take note of my edit above. – chili555 Mar 29 '17 at 13:48
  • it worked as you describe without any problem – gems Mar 30 '17 at 5:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.