I am attempting to install wine on Ubuntu 16.10 and it will not install properly due to issues with the 32 bit packages.

Using the Wine PPA, it cascades down to

wine-staging-i386:i386 : Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed

.... and so on.

Using the standard Ubuntu PPA, it fails when installing wine32:

wine32:i386 : Depends: libwine:i386 (= 1.8.5-1ubuntu1) but it is not going to be installed

And attempts to install those packages create errors about their dependencies, and so on down the line. I have added the i386 architecture:

sudo dpkg --add-architecture i386

And attempted to use aptitude to force the issue, which didn't help. Also, at least in the case of libwine, the amd64 version installed matches the i386 versioning exactly:

Depends: libwine:i386 (= 1.8.5-1ubuntu1) but it is not going to be installed
libwine is already the newest version (1.8.5-1ubuntu1)

I did have an old repository (xenial) installed at one point, but installed no packages from it (I ended up installing the package I needed - libpng12 - manually; installing the i386 version alongside did not fix anything)

Additionally: I have no held packages and no pending updates.


Ubuntu 16.10 offers wine-stable (1.8.5) and wine-development (1.9.20) -- why did you use a wine ppa? Either should install directly with a

sudo apt-get install wine-stable     (or wine-development)  

Use ppa-purge (install if necessary) to get rid of the inconsistent packages you have installed

sudo ppa-purge <whatever wine ppa you used>

and try one of the standard installs.

Since Wine is community supported, you have to enable the universe software source. Run Software Updater, click on the "Settings" buttton, and under the Ubuntu Software tab, click on the "Community maintained free and open source..." checkbox. (first box, Canonical-supported should also have been checked).

The version of libwine:386 on my fresh wine install is 1.8.5-1ubuntu2 not ...ubuntu1

   ii  libwine:i386   1.8.5-1ubuntu2   i386   Windows API implementation - library  

I'd suggest you uninstall every wine package you can identify with

dpkg -l | grep wine

and reinstall wine-stable

sudo apt-get install wine-stable
  • I attempted the separate wine PPA after the Ubuntu 16.10 PPA builds did not work with the wine32 error above. – David N Mar 26 '17 at 22:43
  • Universe is enabled. The standard installs do not work, with the i386 error occurring when I try to install wine32: "Depends: libwine:i386 (= 1.8.5-1ubuntu1) but it is not going to be installed" – David N Mar 27 '17 at 1:25
  • Hmm. The purge / reinstall wine didn't work but it does appear that I have some package version mismatching (such as the libwine package, and some packages matching versions in yakkety/main vs yakkety/updates). Would ppa-purge of non-main packages be worthwhile? Upgrading to 17.10 beta and hope everything syncs better? Thanks for your help. – David N Mar 28 '17 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.