3

I can't get window snapping to work in 16.04 LTS. It has worked previously, and stopped working at some time many months ago. Neither dragging the windows with the mouse, nor the Ctrl-Super-Arrow shortcut work.

Snapping does work on a guest login, so I'm guessing this is some config issue. I've tried deleting my compiz config as per this answer, but no luck. I also tried running sudo dpkg-reconfigure compiz, but not luck. What else can I do?

This is all running on a Intel Core i5-3317U with integrated graphics and the default drivers.

12

I don't know what is the origin of the issue but it seems like an update has overriden some key bindings and options in compiz, to fix it:

sudo apt-get install compizconfig-settings-manager

Then in the windows management options (from the left side panel) check the grid plugin (on the right side). When you click it it will prompt a message warning you that some keybindings are conflicting with others from the general options plugins, click on resolve the issues and replace all the keybindings with those of the grid plugin.

After this snapping and maximize/minimize should be working again.

Credits

| improve this answer | |
  • I wound up reinstalling Ubuntu in the time between asking this question and your answer, which fixed the problem, so I can't verify if your solution works or not. – dericke Jun 26 '17 at 14:18
  • 1
    I can verify that this worked, at least for me. – danShumway Jul 2 '17 at 19:11
  • worked for me too. I believe my settings were changed due to a bad shutdown – Sudhanshu 'Sid' Vishnoi Jan 28 '18 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.