5

The Terminal doesn't show the full results when inputting a command that yields long results.

I want to copy paste them but doing so from the terminal is impossible since it doesn't show the full result.

4
  • 1
    Have you tried seizing the terminal to full-screen?
    – M. Becerra
    Mar 26, 2017 at 14:40
  • 1
    Which version and flavour of Ubuntu are you running? Please describe with an example what you see! Edit your question and add the command and the output from the command. You can copy and paste from the terminal window to the edit window. Add four spaces at the beginning of each line to create 'code' style text.
    – sudodus
    Mar 26, 2017 at 14:41
  • @M.Becerra Yes, and then using the bar in the right I scroll to the very top but that's it... Mar 26, 2017 at 14:45
  • In some terminal windows you can mark all text by shift + ctrl + a and then you can paste it with the middle button into an editor.
    – sudodus
    Mar 26, 2017 at 14:48

2 Answers 2

6

If you are in your terminal, open the Edit drop down menu, select Profile Preferences, and then on the Scrolling tab of the windows that appears, you will see the number of scroll-able lines that the terminal is being limited to. You can increase this number.

Also, using less may help you work with the output:

your_command | less 

Your Enter key will take you down and Q will exit less mode.

Read more at:

How to see more lines in the terminal

2

You can redirect the output into a file, e.g. by:

command > filename.log

Afterwards you can read the file , e.g. by gedit (or any other editor)

gedit filename.log

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.