0
apt-get -f install fails
apt-get upgrade Fails

I am missing many packages required for my companies software

after installing our software several issues started popping up

these are missing dependencies/packages

there are probably others however these are the ones that come up when I search for packages missing dependencies

    libgnutlsxx27:amd64
    libatomic1:amd64
     cpp-4.8
     g++-4.8
     libexpat1-dev:amd64
     libxext-dev:amd64
     libstdc++-4.8-dev:amd64
     libaprutil1-dev
     libquadmath0:amd64
     libcairo2-dev
     libtsan0:amd64
     gcc-4.8
     libfontconfig1-dev
     libgcc-4.8-dev:amd64
    libidn11-dev
     php5-gd
     libldap2-dev:amd64
     php5-curl
     libcairomm-1.0-dev:amd64
     g++ 
     libtasn1-6-dev
     libasan0:amd64
     libgfortran3:amd64
     libpython2.7-dev:amd64
     libpng12-dev
     cpp
     libcurl4-gnutls-dev:amd64
     build-essential
     gcc
     libpython-dev:amd64
     comerr-dev
     libboost1.54-dev
     libhdf5-7:amd64
     libc6:amd64 
     libc6:i386
     libsm6:amd64
     gvfs-daemons
     libboost-date-time1.54-dev:amd64
     libxxf86vm1:amd64
     protobuf-c-compiler
     libboost-mpi1.54.0
     libgnutls-dev
     libv8-3.14.5
     libboost-program-options1.54-dev:amd64
     php5-readline
     postgresql-contrib-9.3
     libpixman-1-0:amd64
     libcolord1:amd64
     libpcre3-dev:amd64
     make
     libgmp10:amd64

When running the init.d command the system stated that the init.d does not exist

I checked the folder and its there

How can I fix it?

sudo apt-get -f install -y
Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies... Done
The following extra packages will be installed:
  comerr-dev cpp cpp-4.8 dpkg-dev gcc gcc-4.8 krb5-multidev libaprutil1-dev
  libasan0 libatomic1 libc6 libcurl3-gnutls libcurl4-gnutls-dev libdpkg-perl
  libexpat1-dev libfreetype6-dev libgcc-4.8-dev libgl1-mesa-glx libglapi-mesa
  libgmp10 libgnutls-dev libgnutlsxx27 libgomp1 libgssapi-krb5-2 libgssrpc4
  libidn11-dev libitm1 libk5crypto3 libkadm5clnt-mit9 libkadm5srv-mit9
  libkrb5-3 libkrb5-dev libkrb5support0 libldap2-dev libpci-dev libpcre3-dev
  libpcrecpp0 libpixman-1-0 libpixman-1-dev libpng12-dev libpq-dev libpq5
  libquadmath0 libsm6 libsqlite3-dev libtasn1-6-dev libtsan0 libxxf86vm1 make
  openjdk-7-jre openjdk-7-jre-headless postgresql-9.3 postgresql-contrib-9.3
Suggested packages:
  doc-base cpp-doc gcc-4.8-locales debian-keyring gcc-multilib automake1.9
  flex bison gdb gcc-doc gcc-4.8-multilib gcc-4.8-doc libgcc1-dbg libgomp1-dbg
  libitm1-dbg libatomic1-dbg libasan0-dbg libtsan0-dbg libquadmath0-dbg
  krb5-doc glibc-doc libcurl4-doc libcurl3-dbg gnutls26-doc gnutls-bin
  krb5-user postgresql-doc-9.3 sqlite3-doc make-doc icedtea-7-jre-jamvm
  libnss-mdns sun-java6-fonts fonts-ipafont-gothic fonts-ipafont-mincho
  ttf-wqy-microhei ttf-wqy-zenhei ttf-indic-fonts-core ttf-telugu-fonts
  ttf-oriya-fonts ttf-kannada-fonts ttf-bengali-fonts oidentd ident-server
  locales-all libdbd-pg-perl
Recommended packages:
  build-essential
The following NEW packages will be installed:
  comerr-dev cpp cpp-4.8 gcc gcc-4.8 libaprutil1-dev libasan0 libatomic1
  libcurl4-gnutls-dev libexpat1-dev libgmp10 libgnutls-dev libgnutlsxx27
  libldap2-dev libpcre3-dev libpixman-1-0 libpng12-dev libquadmath0 libsm6
  libtasn1-6-dev libtsan0 libxxf86vm1 make postgresql-contrib-9.3
The following packages will be upgraded:
  dpkg-dev krb5-multidev libc6 libcurl3-gnutls libdpkg-perl libfreetype6-dev
  libgcc-4.8-dev libgl1-mesa-glx libglapi-mesa libgomp1 libgssapi-krb5-2
  libgssrpc4 libidn11-dev libitm1 libk5crypto3 libkadm5clnt-mit9
  libkadm5srv-mit9 libkrb5-3 libkrb5-dev libkrb5support0 libpci-dev
  libpcrecpp0 libpixman-1-dev libpq-dev libpq5 libsqlite3-dev openjdk-7-jre
  openjdk-7-jre-headless postgresql-9.3
Preconfiguring packages ...
29 upgraded, 24 newly installed, 0 to remove and 105 not upgraded.
337 not fully installed or removed.
Need to get 0 B/65.8 MB of archives.
After this operation, 45.9 MB of additional disk space will be used.
(Reading database ... 82106 files and directories currently installed.)
Preparing to unpack .../libc6_2.19-0ubuntu6.11_amd64.deb ...
Unpacking libc6:amd64 (2.19-0ubuntu6.11) over (2.19-0ubuntu6.5) ...
Extracting templates from packages: 100%
dpkg: error processing archive /var/cache/apt/archives/libc6_2.19-0ubuntu6.11_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libc6/changelog.Debian.gz', which is different from other instances of package libc6:amd64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.19-0ubuntu6.11_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

 sudo apt -f dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  comerr-dev cpp cpp-4.8 gcc gcc-4.8 libaprutil1-dev libasan0 libatomic1
  libcurl4-gnutls-dev libexpat1-dev libgmp10 libgnutls-dev libgnutlsxx27
  libldap2-dev libpcre3-dev libpixman-1-0 libpng12-dev libquadmath0 libsm6
  libtasn1-6-dev libtsan0 libxxf86vm1 linux-headers-4.4.0-66
  linux-headers-4.4.0-66-generic linux-image-4.4.0-66-generic
  linux-image-extra-4.4.0-66-generic linux-signed-image-4.4.0-66-generic make
  postgresql-contrib-9.3
The following packages will be upgraded:
  apache2 apache2-bin apache2-data apache2-dev binutils dbus-x11 dh-apparmor
  dpkg-dev fontconfig fontconfig-config git git-core git-man icu-devtools
  krb5-multidev libapache2-mod-php5 libavahi-client3 libavahi-common-data
  libavahi-common3 libavahi-glib1 libbatik-java libc-ares2 libc6 libcups2
  libcurl3-gnutls libdpkg-perl libdrm-intel1 libdrm-nouveau2 libdrm-radeon1
  libfontconfig1 libfreetype6-dev libfreexl1 libgcc-4.8-dev libgcrypt11
  libgcrypt11-dev libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgl1-mesa-dri
  libgl1-mesa-glx libglapi-mesa libgomp1 libgraphite2-3 libgssapi-krb5-2
  libgssrpc4 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libharfbuzz0b
  libibverbs-dev libibverbs1 libicu-dev libicu52 libidn11-dev libitm1
  libjasper-dev libjasper1 libk5crypto3 libkadm5clnt-mit9 libkadm5srv-mit9
  libkdb5-7 libkrb5-3 libkrb5-dev libkrb5support0 liblcms2-2 liblwgeom-2.1.2
  libmysqlclient-dev libmysqlclient18 libnspr4 libnss3 libnss3-nssdb
  libpci-dev libpcrecpp0 libpixman-1-dev libpoppler44 libpostgis-java
  libpq-dev libpq5 libpulse0 libsndfile1 libsqlite3-dev libssl-dev libssl-doc
  libssl1.0.0 libsvn1 libtdb1 libtiff4-dev libtiff5 libtiff5-dev libtiffxx5
  libuuid1 libxerces-c-dev libxerces-c3.1 libxfixes3 libxfont1 libxi6 libxml2
  libxml2-dev libxrandr2 libxrender-dev libxrender1
  linux-headers-generic-lts-xenial linux-libc-dev
  linux-signed-generic-lts-xenial linux-signed-image-generic-lts-xenial
  munin-common munin-doc munin-node munin-plugins-core munin-plugins-extra
  mysql-common openjdk-7-jre openjdk-7-jre-headless php-pear php5 php5-cli
  php5-common php5-pgsql postgresql postgresql-9.3
  postgresql-9.3-postgis-scripts postgresql-client-9.3
  postgresql-client-common postgresql-common postgresql-contrib
  postgresql-server-dev-9.3 subversion tzdata tzdata-java unzip uuid-dev wget
  x11-common x11proto-core-dev xtrans-dev
134 upgraded, 29 newly installed, 0 to remove and 0 not upgraded.
337 not fully installed or removed.
Need to get 67.2 MB/189 MB of archives.
After this operation, 348 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Fetched 67.2 MB in 1min 3s (1,053 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 82106 files and directories currently installed.)
Preparing to unpack .../libc6_2.19-0ubuntu6.11_amd64.deb ...
Unpacking libc6:amd64 (2.19-0ubuntu6.11) over (2.19-0ubuntu6.5) ...
dpkg: error processing archive /var/cache/apt/archives/libc6_2.19-0ubuntu6.11_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libc6/changelog.Debian.gz', which is different from other instances of package libc6:amd64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.19-0ubuntu6.11_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • 1
    Please run this sudo apt update, then sudo apt dist-upgrade – George Udosen Mar 26 '17 at 10:53
  • You have to show the full command and output, partial snippets are pretty useless to troubleshoot such an issue. – Byte Commander Mar 26 '17 at 11:26
  • 1
    ran sudo apt -f dist-upgrade – user669890 Mar 26 '17 at 11:45
  • had to remove links would not allow me to post more than 2 – user669890 Mar 26 '17 at 11:51
0

i fixed the issue

what happened was when i installed all the dependencies for Symantec Endpoint Protection Client (JAVA,unlimited-JCE, repositories, libs)

It caused an incompatibility with our software, which messed everything up.

what we did to fix it was start fresh with a clean install with only the OPENSSH-SERVER installed so we could connect to it without using the VM Host machine

ran the sudo apt-get update/upgrade

then i followed the steps for installing our software

then ran sudo apt-get update sudo apt-get upgrade (failed missing dependencies) sudo apt-get -f install (succeeded) sudo apt-get upgrade (succeeded)

then installed all the dependencies for the Symantec and installed it

System is up and running with no issues

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.