I faced strange issue, as usual after wake up (during work), every popup window (menu, list and etc) appeared with with a border like on the picture. Ubuntu 16.04. Only relogin or restarting helps. It never happened before this week.

enter image description here

  • Yes, look at Kaz Wolfe answer it contains link to this question
    – rpc1
    Apr 12, 2017 at 14:32

3 Answers 3


Here we go again...

This is currently a bug with NVIDIA's drivers, and is pending a fix on their end. In the meantime, a bug against Compiz was opened to solve the same issue. While we wait for someone to fix this, there are still workarounds:

  • Downgrade Drivers
    This bug was introduced after driver 367.57. Therefore, just downgrading to that version (or lower) will resolve this issue. Some users have reported success downgrading to 370.28 as well.
  • Switch to Intel graphics
    If you're running NVIDIA Prime/Optimus, switching your system to use the integrated Intel card will resolve this issue. Note, however, that this will result in a pretty sharp performance loss.
  • Use An Experimental Patch
    Kai-Heng Feng from the aforementioned Compiz bug report has released a modified version of unity on his PPA which resolves this problem pending a more formal fix from either Unity/Compiz or NVIDIA. To install this patch, run the below commands, and then reboot:

    sudo add-apt-repository ppa:kaihengfeng/lp1292830 
    sudo apt update
    sudo apt full-upgrade

In the meantime, a temporary workaround to this same problem would be to run the unity command from a terminal or the Alt-F2 menu every time this issue is encountered.

  • Nice set of workarounds.
    – Elder Geek
    Apr 4, 2017 at 13:52
  • Note that running unity will close any open applications.
    – kurja
    May 1, 2017 at 15:00

I made some steps which solve my problem, but don't know what exactly helps 1. I change driver to X.org open source from NVIDIA enter image description here

  1. Install all system updates

  2. Restarted OS, issue didn't occurred after it...

I hope it helps me... After it I tried to returned NVIDIA drivers... and it works well.. may be video drivers was corrupted.

  • 1
    I have the same problem with the same drivers. I wasn't able to solve it.
    – manifold
    Mar 28, 2017 at 10:53
  • I didn't face issue anymore.... these steps helps me
    – rpc1
    Mar 28, 2017 at 19:03
  • @ShreyashSSarnayak see Kaz answer here. for more options.
    – Elder Geek
    Apr 4, 2017 at 13:56
  • This worked for me. Ubuntu 17.04
    – Wei Ma
    Oct 13, 2017 at 16:34

Kaz Wolfe said to downgrade to at least 367.57 or lower, but I downgraded my nvidia driver version to 370.28 and the problem is gone.

Also, I downgraded to an open source version and not proprietary.

Not the answer you're looking for? Browse other questions tagged or ask your own question.