1

I installed Ubuntu on my iMac. At first, the sound wasn't working but that was because it was on Analog Stereo Output and not on Analog Surround 4.0 Output. But now, when I adjust the volume slider is stays at the same volume (loudest) no matter where it is. (With the exception of mute)

When I put my headphones in, everything works fine. I've tried basically every solution on the internet so far and couldn't find anything. For some reason when I adjust the PCM the volumes goes down and up, but Master does nothing.

2

I had a similar issue on my Asus UX550VD on Ubuntu 16.04, 17.10 and 18.04. I can only confirm the fix for 18.04.

To build a bit more of an understanding of the various sound control, I recommend you run

$ alsamixer

in a shell, and play around with the various levels to understand what they do (as well as see how your volume controls change the levels).

On my machine, I found that the master volume did nothing. Only changing the PCM values would adjust the volume on my speakers. My volume control would only change master though. Hence the volume remaining the same regardless of the displayed volume.

I found a fix to adjust PCM instead of master from https://forums.linuxmint.com/viewtopic.php?t=91453

To reiterate the fix:

(Make sure to backup the file before it, just in case something goes wrong)

In this file

/usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common

I added in

[Element Master]
switch = mute
volume = ignore

just before this block

[Element PCM]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

This means the master volume is ignored entirely and you will instead configure the PCM volume when using the volume controls.

I rebooted machine and my volume worked as expected. Look at alsamixer to double check the behavior in case it doesn't work (I had a typo in my config the first time I did this).

  • thanks man, it works even on 19.10 – Vahe Shadunts Nov 6 at 19:17
0

I had similar problem on an Asus laptop with Kubuntu 17.04. There is an Analog Surround 4.0 Output, and the sound was coming through this. When using the volume keys to change audio output the slider would move but the actual volume of the sound would stay at max (except mute).

In System Settings>Multimedia>Audio Settings>Configuration. I first changed the sound device to Analog Stereo 2.0 and then the volume keys not only moved the slider but also did change the actual volume of the sound. Obviously this meant stereo rather than 4.0 and so was unsatisfactory.

In the end I found following solution, but have no idea why it works. In System Settings>Multimedia>Audio Settings>Configuration, I set the sound device to Analog Surround 4.0, I also ticked the "Add virtual output device for simultaneous output to all local sound cards". Under System Settings>Multimedia>Audio Settings>Output Devices, I set 'Simultaneous Output to Built-in Audio Analog Surround 4.0' to be the default channel. Now have the 4.0 sound and the volume keys work to change it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.