I am new to Linux. I installed Ubuntu 16.04.2 LTS alongside windows 10 on a separate partition using Unetbootin . Whenever I started my notebook it used to present me with dual boot options. I booted into windows 10 and deleted ubuntu from the hard drive using windows 10 disk management utility. I extended the volume of one partition in windows 10. Then I rebooted my notebook and found out that I was unable to boot into windows. When I reboot Grub rescue black screen is displayed.

By going through the top answers in the forum I have tried the following methods to fix the grub.

Method 1: I typed "ls" to list all the partitions on the grub rescue screen and tried setting root to each of the partitions. But on each partition I got "file system unknown error".

Method 2: I booted into ubuntu using ubuntu live usb and tried the second option under boot repair method mentioned on this link:- https://help.ubuntu.com/community/Boot-Repair

I got a pop up message:- "Boot successfully repaired. You can now reboot your computer"

But when I rebooted it again it displayed the grub rescue black screen. A pastebin link was also generated after boot repair.

Pastebin Link -> http://paste2.org/5X6UaEjn

METHOD 3: I wanted to boot into windows 10 using bootable pen drive so that I can enter the command prompt of windows 10 and delete the grub using Bootrec /fixmbr. So I downloaded windows 10 iso from microsoft and created a bootable usb drive using Unetbootin. Then I booted from the pen drive containing windows 10 iso but the problem is it is not able to boot from the pen drive. Whenever I start my notebook I get an acer logo screen followed by a screen displaying message "NO BOOTABLE MEDIA". Now when I try to boot hard drive by setting it as first priority boot media I again get a "NO BOOTABLE MEDIA" message on the screen. I no longer get grub rescue screen which I used to get after booting the hard drive.

Please help because I don't want to lose my data.

Notebooks Specs: Acer E5-511 Windows 10, 500 gb hard drive, 2 GB ram



Not an answer but I don't have enough rep to comment. Are you able to get into Windows at all? This seems due to the MBR and if you can get into Windows then I would know the steps from there.


You have as a default boot the wrong one, have you tried to enter into BIOS settings and change the order of the boots?

  • Press F12 or F9(it changes among computers)
  • Switch tabs till you reach the "BOOT LOADER" or similar
  • Select the windows boot loader and move it to the first position

It is not a solution although not bad workaround.

  • I pressed F2 to enter the bios and selected pen drive containing the windows os as the first option and hard disk as the second option. But it loops through a series of blank screens and acer logo. – akshay Mar 25 '17 at 19:11
  • In that case, the boot loader of windows it should be broken. Try to catch a bootable pen drive with windows and put it as a first boot device. Then when the windows 10 screen appears select the repair option – Bechma Mar 25 '17 at 20:03
  • To ease the process I think this page can help you boyans.net/RepairWindows/repair-windows-boot.html – Bechma Mar 25 '17 at 20:06
  • I tried the same pen drive on another pc and it started windows 10 installation setup. But on my pc it gives an error "No bootable Media". – akshay Mar 25 '17 at 20:27
  • What program did you use to make it bootable? If you used windows USB tool try RUFUS or the opposite. It can occurs that grub faces problems to recognize the OS files in the USB – Bechma Mar 25 '17 at 20:39

I was able to boot into windows live usb after changing boot mode from UEFI to LEGACY. Then I deleted the grub using fixmbr command. But it shows me NO BOOTABLE MEDIA error when I try to boot into windows using UEFI mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.