0

This question already has an answer here:

Ok. I really need help. I messed up Ubuntu 16.04 LTS so I decided that upgrading to 16.10 will fix the broken packages. It did, but now I can't use the internet. At all. I have a Lenovo Ideapad with Realtek ethernet adapter. It says that the ethernet is "not managed". I tried modifying the managed=false to managed=true in /etc/NetworkManager/NetworkManager.conf but that didn't work. Can anybody help me?

marked as duplicate by jokerdino Apr 18 '17 at 7:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

For me the following commands solved the issue and LAN connection was immediately detected.

sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
sudo service network-manager restart

if the above doesn't work try the following

sudo sh -c "echo 'net.ipv6.conf.all.disable_ipv6 = 1' >> /etc/sysctl.conf"
sudo sh -c "echo 'net.ipv6.conf.default.disable_ipv6 = 1' >> /etc/sysctl.conf"
sudo sh -c "echo 'net.ipv6.conf.lo.disable_ipv6 = 1' >> /etc/sysctl.conf"
sudo sysctl -p
sudo sed -i 's/false/true/g' /etc/NetworkManager/NetworkManager.conf
sudo reboot -i NOW

Good luck!

  • excellent! the "touch" command plus reboot did the trick for me... – user17254 Jul 29 '17 at 11:45
0

I solved the problem. Unfortunately, I needed to reinstall Ubuntu 16.10. And now I need to reinstall all the programs. Because Ubuntu live-USB doesn't have "Repair Current Install", which I consider a shame, since may other distros have that.

Not the answer you're looking for? Browse other questions tagged or ask your own question.