1

Not sure why this started happening, but now Ubuntu 16.10 just boots directly to the login screen, without showing the UEFI/BIOS logo or GRUB menu for dual boot. I haven't changed any settings to deal with booting; it was working perfectly before.

1

The previous answer about Boot-Repair is unlikely to fix your issue. Since your Ubuntu is booting we know that you have a working bootloader.

You should be able to press SHIFT during boot to bring up the grub menu, however that can be tricky timing it right sometimes.

Information related to this question can also be found in this previous question, even though they are not using dual-boot the information is identical for grub/grub2: How to get to the GRUB menu at boot-time?

It is likely that somehow GRUB_HIDDEN_TIMEOUT and/or GRUB_TIMEOUT got changed in your /etc/default/grub You can change these to something other than zero (in seconds) and then run: sudo update-grub

After this your grub menu should show on your next reboot.

  • Unfortunately, neither solutions worked. The UEFI logo doesn't show at the start like it usually does, and neither does the GRUB menu. The grub file was intact. – fu_______ Mar 25 '17 at 13:24
  • @fu_______ If SHIFT key doesn't work, you can try to press ESC key at boot time. This should show you Grub menu. – Danibix Mar 25 '17 at 13:27
  • I've fixed it...somehow. I downloaded Grub Customizer and saved the configuration and it seemed to fix all my problems. Windows had to fix some disk errors but other than that it solved my problems. – fu_______ Mar 25 '17 at 14:23
0

You should try to boot from live USB. After that, install Boot-Repair with
sudo add-apt-repository ppa:yannubuntu/boot-repair sudo apt-get update sudo apt-get install -y boot-repair && boot-repair
After that, it should guide you to re-installing GRUB. It should work.

0

You note in a comment to another answer that you've gotten it working; however, that comment also notes that Windows complained of disk errors. This makes me think that you may not have disabled Fast Startup and/or Hibernate in Windows. See these pages for instructions on how to do so:

If you don't disable these Windows features, the result can be damage to filesystems shared between Ubuntu and Windows, including the EFI System Partition (ESP), which is where EFI boot loaders live. This could have resulted in GRUB's configuration scripts failing to detect Windows after a GRUB or kernel update; and when that happened, the GRUB timeout and menu-display options might have been altered to prevent the menu from showing up.

This explanation is highly speculative, of course, and there are other things that could cause damage to the ESP's FAT filesystem, such as a system crash, a bug in some tool that accesses the ESP in a low-level way, or user error. Ubuntu's installer doesn't warn you to disable those Windows features, though, so failing to do so is a common mistake.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.