1

I have been using VMware Player for a long time on 14.04. I updated to 16.04 about 3 months ago. Now I am trying to launch VMware Player for the first time since the upgrade, and it refuses to launch! I double click the shortcut on my launcher, then the program tries to launch as usual by appeaing in the bottom taskbar with a message "Starting VMware Player", and after a few seconds it simply disappears with no error!

enter image description here

I tried the following with no change:

  1. I reinstalled a slightly newer version. From version 6 to 7 (VMware-Player-7.1.2-2780323.x86_64.bundle)

  2. I found this post vmware error after upgrade to ubuntu 16.04 and disabled secure boot in bios.

  3. I read this post VMware wont run in ubuntu 16.04 LTS (No Error msg even) and people are saying VMware Player sucks. But I have been using it for about 5 years on Ubuntu and have never had an issue up to now.

  4. Of couse I ran the update just in case...

All info above is the original problem - I launch VMplayer and it does not launch with no error message or any dialogue boxes. Everything below is the current problem where I have a bunch of errors with compiling modules and loading them into the kernel after trying some terminal commands

  1. I found this post VMware won't work after Ubuntu Upgrade. I ran export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libglibmm-2.4.so.1/:$LD_LIBRARY_PATH and it looked like it was about to start... i was asked to update the kernel, I enter the password enter image description here

    and the process fails with this message:

    (vmware-gksu:4905): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
    (vmware-gksu:4905): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
    Gtk-Message: Failed to load module "canberra-gtk-module"
    
  2. using the comments in vmware player on ubuntu 15.10 I ran echo /usr/lib/vmware/lib/libglibmm-2.4.so.1 | sudo tee -a /etc/ld.so.conf.d/LD_LIBRARY_PATH.conf and sudo ldconfig. Also I ran sudo apt-get install libcanberra-gtk*

after trying all those commands, when I type vmplayer at the terminal I am asked for a password to compile the kernel, and once that process launches it fails. Image below gives you a gist of what I am seeing.

The contents of the terminal after vmplayer can be found here: https://paste.ubuntu.com/24246599/

The contents of the error log can be found here: https://paste.ubuntu.com/24246694/

enter image description here

My high level questions is how do I get VMware Player version 6 or 7 to work with 16.04?

I am sure it's important to mention that the post in the second ordered list above suggested running sudo modprobe vmnet. I am not sure what information this command is providing, but here it is: modprobe: FATAL: Module vmnet not found in directory /lib/modules/4.4.0-66-generic

Any suggestions or advice are much appriciated!

  • @DavidFoerster Hi David, thanks for putting a link to the pastie service. I pasted everything the terminal spewed after typing vmplayer there, along with the error log. – Mike Mar 25 '17 at 12:33
  • Which command did you run to start the build process of the VMware kernel module(s)? – David Foerster Mar 25 '17 at 14:58
  • @DavidFoerster I type vmplayer and I am automatically prompted to compile and load VMware modules into the kernel. If I am misunderstanding your question and you are asking which commands I typed to be prompted (as my original problem the VMplayer would simply not launch), they are detailed in number 5 and 6 in the post. Please let me know if I can run any commands or provide any type of information. Thank you for your help. – Mike Mar 26 '17 at 3:42
1

I'm having a similar problem with vmware player 12.5.6. I can compile vmmon and vmnet (you need to install build-essential and linux-headers-generic). However they won't load into the kernel. vmware suggests turning off safe boot (which I already had disabled) or signing the modules (which makes no difference, as I'm not running secure boot or UEFI). If you want try that, see the answer here: vmware error after upgrade to ubuntu 16.04

To answer your basic question, you can find vmware player 7 here: https://my.vmware.com/en/web/vmware/free#desktop_end_user_computing/vmware_player/7_0|PLAYER-714|product_downloads

First you'll need to uninstall your current vmware player:

sudo vmware-installer -u vmware-player

After you install vmware player 7.*, you need to add a line to your .bashrc in order to get vmplayer to start:

export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libglibmm-2.4.so.1/:$LD_LIBRARY_PATH

which came from this answer: VMware won't work after Ubuntu Upgrade

Still having my issue with vmmon not loading into the kernel though... but at least vmplayer starts.

0

try sudo apt-get install open-vm-tools then download and run the install for vmplayer 12.5

  • thanks for the suggestion, but I am really set on making ver. 6 or ver. 7 work. I move my VM across many PCs and if I use the VM in ver. 12.5, I may not be able to use in in another machine that uses ver. 6. I'll try your suggestion with Ver. 6 – Mike Mar 25 '17 at 2:21
  • Vmware.com statement on open-vm-tools, I should have included this earlier. Likely the open-vm-tools, may already be installed, and the provided link may offer assistance in other areas. Good lock. – dajavex71 Mar 25 '17 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.