This question already has an answer here:

I am new to Ubuntu and so far I have this problem: I've tried to install skype and couldn't do it. Then the software "app" stop working and I get an error of Failed to load the package list, followed by details:

E:Malformed entry 55 in list file /etc/apt/sources.list (Component),  
E:The list of sources could not be read.

I'm really rookie at this, but I've tried my best figuring out through older ask ubuntu questions of the "E:Malformed entry 54" but that is not working.

Please help.

marked as duplicate by karel, Pilot6, Jacob Vlijm, Zanna, muru Mar 25 '17 at 22:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please copy and paste the output of cat /etc/apt/sources.list into your question, select it, and press the {} button in the editor. – Chai T. Rex Mar 25 '17 at 0:48
  • And what exactly did you do from the previous posts that did not work? – muru Mar 25 '17 at 5:35
  • @muru do you know why the down vote on the question, and my accepted answer? – heynnema Mar 25 '17 at 22:01
  • @heynnema on the question, see my comment. On your answer, I don't know, but I can add one more if you like. – muru Mar 25 '17 at 22:02
  • @muru an up vote would make me feel so much better :-) – heynnema Mar 25 '17 at 22:03

To fix your problem...

In terminal...

cat -n /etc/apt/sources.list

observe the contents of line #55. That's where your error is. Normal lines start with deb http:// or deb-src http:// or #.

Backup the file...

sudo cp /etc/apt/sources.list /etc/apt/source.list.backup

Now to edit out the problem...

gksudo gedit /etc/apt/sources.list


sudo -H gedit /etc/apt/sources.list

and place a # at the front of the offending line to comment it out. Save the file and quit gedit.

update #1

I've looked at your sources.list file, and I've found the problem. Unfortunately imgur.com makes a graphic image of the pasted text, so I can't just copy/paste the error lines here, so I'll have to use a graphic...

enter image description here

You'll see that the last 2 lines are duplicates of the first two lines, except that they're incomplete, and the 3rd line is specifically the one causing your problem.

Since you've been having a problem with gksudo, and with gedit, we'll give an example using the pico editor...

sudo pico /etc/apt/sources.list

Remove the last two incomplete lines shown in my graphic, then save and quit.

Pico note: use arrow keys to move, control-o, enter, control-x to save and quit.

  • First of all, thank you very much for the quick response. Second: I reboot the computer and now the problem is in the 45th line (of 48), now, when I use the gksudo gedit /etc/apt/sources.list command, the terminal says that the gksudo program isn't installed, when I try to install it goes: N: «50unattended-upgrades.ucf-dist» del directorio «/etc/apt/apt.conf.d/», extention of file name invalid (I'm translating from spanish...) E:Malformed entry 55 in list file /etc/apt/sources.list (Component), E:The list of sources could not be read. ?? – Leo Lacarne Mar 25 '17 at 12:05
  • Then use sudo -H gedit /etc/apt/sources.list. If you have more problems, do a cat /etc/apt/sources.list, copy/paste that output into your original question, and I'll take a look. Start new comments directed to me with @heynnema or I may miss them. – heynnema Mar 25 '17 at 14:15
  • I did the sudo -H gedit /etc/apt/sources.list and nothing was weird with it, either way, I put a # save and exit and this showed up: (gedit:2448): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files ** (gedit:2448): WARNING **: Set document metadata failed: Establecer el atributo metadata::gedit-spell-enabled no está soportado ** (gedit:2448): WARNING **: Set document metadata failed: Establecer el atributo metadata::gedit-encoding no está soportado) – Leo Lacarne Mar 25 '17 at 18:47
  • Boy, you're having your share of problems, huh? Then do as I suggested, cat /etc/apt/sources.list, copy/paste it into your original question, and I'll take a look. When starting new comments directed to me, start them with @heynnema or I may miss them. Let me know when I can take a look at your edit. – heynnema Mar 25 '17 at 18:50
  • @heynnema Yup, I've been hours here trying to solve this, with the knowledge of a typewriter user. I've tried to edit the original question adding the copy/paste but the page says that I need 10 or more points of reputation to post more than 2 links... Thank you for your patience. – Leo Lacarne Mar 25 '17 at 19:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.