2

First off, this is my first foray into the world of Linux and I'm liking it so far. I followed this guide (which was very good) and got Ubuntu 14.04 Trusty Xfce to work very well.

However I've run into a bit of an annoying issue. I've somehow lost the taskbar that was at the top of the screen and the icons at the bottom. I don't really know what the correct names of those are but I'd very much like to get them back.

enter image description here

I don't know what I did to lose them, but I lost them upon the first restart I did to see if I could get back into Ubuntu, which I was able to. Any help is much appreciated.

2

Press Ctrl+Alt+T to open a terminal:

Type:

xfce4-panel

OR

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install --reinstall xubuntu-desktop
sudo shutdown -r now

IF you can't access to a terminal use the shell:

Press Ctrl+Alt+F1

Type your username and password

sudo service lightdm stop
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install --reinstall xubuntu-desktop
sudo shutdown -r now
1
  • Thank you very much! The first command worked a charm. I'll favorite this so I don't forget it. Mar 25 '17 at 0:57
1

To execute the command xfce4-panel automatically everytime you boot you must:

Open Session and Startup from the XFCE menu or type into a terminal:

Press Ctrl+Alt+T and type:

xfce4-session-settings

Click on Tab Application Autostart

Click on +Add

Name: Anything you like

Description: Anything you like

Command: xfce4-panel

Click OK

Make sure is listed in the menu and also the check box must be ticked.

Do a reboot to check

sudo shutdown -r now
1
  • Thanks again for another useful tip, I didn't know that the problem was it wasn't launching the panel on boot. Worked like a charm. Mar 25 '17 at 1:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.