0

My Samba install was working fine, until I decided to organize the many folders into subfolders. Now I can still connect to the Samba share and see the subfolders, but I can't look inside them. Even the subfolders that were fine before can't be opened. Video files in the share folder are able to play.

I have tried many variations of files permissions and ownerships, but nothing seems to work. Any suggestions on how to fix this?

[video]
path = /home/scott/video
comment = No comment
read only = yes
available = yes
browseable = yes
writable = no
guest ok = yes
public = no
printable = no
locking = no
strict locking = no


drwxr-xr-x  6 scott  scott       24576 Mar 24 14:37 ./
drwxr-xr-x 98 scott  scott        4096 Mar 24 14:02 ../
drwxr-xr-x 61 scott  scott        4096 Mar 24 12:49 AtoE/
-rw-r--r--  1 scott  scott  1668731824 Mar 24 02:47 movie1.mkv
-rw-r--r--  1 scott  scott  1695138223 Mar 24 02:47 movie2.mkv
-rw-r--r--  1 scott  scott          57 Sep  9  2016 .directory
drwxr-xr-x 74 scott  scott       12288 Mar 24 03:55 FtoN/
drwxrwxr-x  2 nobody nobody       4096 Mar 24 14:37 junk/
drwxr-xr-x 87 scott  scott        4096 Mar 24 11:44 OtoZ/

Note that the permissions for this folder, which is accessible, are the same as for the subfolders that are not. I tried smbguest as a directory owner as well, and that didn't work.

  • Need a few more details here. What exact error message do you get when trying to access a folder? Is this a server you're connecting to from some other device? Have you tried running smbclient on the server? – nickcrabtree Mar 25 '17 at 7:23
0

Turning up the debug level showed that the problem is this bug in Samba filed yesterday.

Adding follow symlinks = yes to each share section in smb.conf resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.