Today I tried several times to install Ubuntu but I have some GPU problems.

I have a bootable stick. When I boot in UEFI mode all its normal but the installer isn't able to install the boot loader.

When I boot in leagacy mode I'm able to install Ubuntu but only when I unplug my GPU GTX 1070.

When I don't do that, I get an this initialization error from the installer:

3.021954] nouveau 0000:01:00.0: unknown chipset (134000a1)

I installed Ubuntu normally without the GPU. I installed the drivers, rebooted, shut down, pluggeed in the GPU and tried to boot but it got stuck at:

/dev/mapper/isw_bdifbbjbai_Raid0p3: clean, 191449/8855552 files, 1677252/34500448 blocks

What should I do? When I unplug the GPU I can boot easily, but I need my GPU! :D

My PC has a GTX 1070 GPU, i7 4790K CPU, and two hard drives:

  • 250 GB M.2 SSD, which contains Windows 10 and its boot loader.
  • 2 TB RAID-0 WD, with 1,85 TB for Windows 10 files and 150GB where I installed Ubuntu and its boot loader.
up vote 1 down vote accepted

I had a similar problem with my GTX 1080 when installing Ubuntu 16.04. It seems that 16.04 does not support the latest Nvidia GPUs. I finally managed to install Ubuntu 16.04 along side with Windows 10 dual boot with my GTX 1080 unplugged. What I did is as follow.

  1. Before you install Ubuntu, go to BIOS setting and disable the GTX GPU. You may need to go through the BIOS settings for sometime to find the right option (something like IGX?).
  2. Note that before you reboot, you need to switch your monitor's cable to the motherboard video output, since after reboot, the GTX GPU would be disabled and you would not see anything.
  3. After that, choose the install media with UEFI, and go through the installation procedure as usual. The display should be alright.
  4. At the position where it asks on which device you want the Ubuntu installed, choose manual setting (the something else button?). And make partitions as you like. But remember to choose the whole device (i.e. /dev/sda or /dev/sdb) to install grub. DO NOT choose something like /dev/sda1.
  5. After the installation finished, reboot without changing graphical output device.
  6. When you are in your newly installed Ubuntu, open a terminal and install the appropriate Nvidia driver. You may check this question for more details. It's basically sudo add-apt-repository ppa:graphics-drivers/ppa sudo apt-get update and find the right driver for you. Check this also.
  7. Finally, reboot and change the graphical output device back to your GPU and everything should work normal. You can type nvidia-smi in a terminal to check if the driver is working.

One of my friend tried to install Nvidia driver from Ubuntu system setting. You may look into that as well. As for me, the above procedure works fine.

Thanks for you answers but in the meantime I fixed my problem by installing Ubuntu 17.04 beta 2. I was able to install it without any problems.

The driver I installed with the help of the blog post Installing Nvidia's Proprietary GTX 1070 and 1080 Driver in Ubuntu 16.04. How to Get Around The "out of range" Error and a Guide to Do a Realtime monitoring of your GPU.

Once 17.04 is installed, the driver may be installed (as that blog post says) by running:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-367

1. Make sure that your GRUB is set right:

a.For Non UEFI, Download boot-repair-disk https://sourceforge.net/projects/boot-repair-cd/files/ and repair the grub maybe is not installed on the GNU/Linux partition, do a repair just to be sure.

b.For UEFI see http://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd.

2. Use the latest Nvidia Proprietary Drivers IF the Free-Open-Source-Drivers not working like it should:

Go to https://www.nvidia.com/Download/index.aspx?lang=en-us and download the latest Proprietary drivers according to your Nvidia card.

Then press Ctrl+Alt+F1

Type your username and password

sudo service lightdm stop

cd /home/YoUrUsErNaMe/Downloads (or anywhere that is the Nvidia *.run file that you have downloaded)

sudo sh NVIDIA-Linux-x86*(Or type sudo sh NVIDIA- and press Tab and then Enter)

Choose yes to: Automaticly nvidia drivers to stop nouveau (default driver)

sudo shutdown -r now


IF you see bad resolution is totally OK nouveau was disabled by Nvidia.

Press Ctrl+Alt+F1

Type your username and password

cd /home/YoUrUsErNaMe/Downloads (or anywere that is the Nvidia *.run file that you have downloaded)

sudo service lightdm stop

cd /home/YoUrUsErNaMe/Downloads (or anywere that is the Nvidia *.run file that you have downloaded)

sudo sh NVIDIA-Linux-x86* (Or type sudo sh NVIDIA- and press Tab and then Enter)

sudo shutdown -r now

Hope it helps.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.