4

I understand that snap packages offer controlled environments to protect a novice user from inadvertently damaging their system. But I have a need here that I don't think is too far out there.

I have a network attached disk that has a common documents volume for all of the computers on my network. It is accessible to my windows machines as well as to my android devices. Its mount point on my ubuntu system is in the root directory at /netgear (there are actually 3 mount points below this - /netgear/documents, /netgear/downloads, and /netgear/stage). The problem is that /netgear does not appear on the file open dialogs within my snap application (cloudcompare is the specific package I am using).

Things I've tried so far:

  1. I installed the snap with --devmode, but it still does not show my mountpoint. I can see other directories in the root, but not /netgear.
  2. I then changed the mount point to be within the /mnt directory since THAT directory was visible, but the mounted volumes still do not appear within the snap application (/mnt appears as being empty).
  3. Creating a symbolic link in my home directory that pointed to the mount point. I could access the files using native applications, but the link did not show up within cloudcompare (still with --devmode set).
  4. I even tried setting a symbolic link to a normal file on the volume in my home directory, but when I navigated to my home directory in the app, the file was not among my choices.

Things you might need to know - this is a permanent mount done at boot time via the /etc/fstab file. The directories are all mode 777. The entries in my fstab file are as follows:

//netgear/documents /netgear/documents cifs uid=1000,gid=1000,rw,iocharset=utf8,credentials=/etc/.smbcredentials 0 0 //netgear/downloads /netgear/downloads cifs uid=1000,gid=1000,rw,iocharset=utf8,credentials=/etc/.smbcredentials 0 0 //netgear/stage /netgear/stage cifs uid=1000,gid=1000,rw,iocharset=utf8,credentials=/etc/.smbcredentials 0 0

Thanks in advance.

  • There's an interface called removable-media that covers access to devices in /media. I know that works with physical drives, but I've not tried a remote mount there. – Kyle Mar 24 '17 at 17:55
3

Kyle - I tried your suggestion. I moved all mount points to the /media directory - and it worked perfectly. Plus now all of the mount points show up in the left pane of the file explorer (nautilus???)

This suggestion does not work on its own though. One of the following must be done.

  1. Install the app using --devmode, or
  2. Connect the app's :removable-media plug to the :removable-media slot by issuing the command sudo snap connect <app>:removable-media :removable-media

Option 2 is probably preferable, but it requires that the snap be built with the :removable-media plug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.