1

I just installed Ubuntu 16.04 on a Compaq Presario CQ57 laptop (came out around 2012). The machine has a Realtek RTL8188CE wifi adapter. It's still going strong! However, now that I've switched to Ubuntu the wifi is not working. The wifi discovery button on the keyboard is always red, even if I press it. And when I turn on "Enable Wi-Fi" in the network settings under Wi-Fi Networks "Wi-Fi is disabled" is shown in grey. I'm stumped.

UPDATE: I just got a USB wifi adapter to try. The laptop recognizes it, but won't let me turn it on via command line or GUI. In the GUI I click the on/off switch to "on" and it instantly returns to "off". So strange.

First I followed all the suggestions on this similar question post Can't view Wifi networks after upgrading to Ubuntu 16.04.

Output of iwconfig:

lo    no wireless extensions.

wlo1  IEEE 802.11bgn ESSID:off/any
      Mode:Managed Access Point: Not-Associated Tx-Power=off
      Retry short limit:7  RTS thr=2347 B  Fragment thr:off
      Power Management:on

eno1  no wireless extensions.

Output of iwlist scan:

lo    Interface doesn't support scanning.

wlo1  Failed to read scan data : Network is down

eno1  Interface doesn't support scanning.

After service network-manager restart, ethernet disconnected but still could not activate wifi.

Output of sudo rfkill list:

0: phy0: Wireless LAN
         Soft blocked: no
         Hard blocked: yes

1: hp-wifi: Wireless LAN
            Soft blocked: yes
            Hard blocked: yes

So then I tried:

sudo ifconfig wlp4s0 up
service network-manager restart

wifi is still disabled...

I then went into the BIOs and could not find Secure Boot (to turn it off). I did find Boot Order, and enabled the Network Adapter to power on at boot.

bcmwl-kernel-source
sudo apt-get purge bcmwl-kernel-source
sudo apt-get install linux-generic bcmwl-kernel-source
reboot

EDIT: I purged bcmwl-kernel-source by recommendation.

I followed the similar AskUbuntu question over here Wireless not working on Toshiba Satellite C55-A5281 answer by @chili555, and installed some headers with sudo apt-get install linux-headers-generic build-essential, all of which were already installed and up to date. Then I downloaded a backport from 07/30/2013 and unzipped it.

Output of make defconfig-rtlwifi:

Generating local configuration database from kernel....kernel version parse failed! 
Makefile:40: recipe for target 'defconfig-rtlwifi' failed 
make: ***[defconfig-rtlwifi] Error 1

So now I'm stuck again. Should I download another backport or try something else?

  • Instead of service network-manager restart you can try systemctl restart network-manager.service – M. Becerra Mar 24 '17 at 17:02
  • Please don't follow instructions that are chipset specific and different than yours. At some point you installed Broadcom drivers (you have Realtek) that did nothing, best case scenario, or worsened the problem. I would start by removing them with sudo apt-get purge bcmwl-kernel-source. – user589808 Mar 24 '17 at 17:40
  • @CelticWarrior thank you, I did not know that bcm stood for Broadcom – cssidy Mar 24 '17 at 18:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.