3

I have a problem similar to that of this question.

A few days ago, I created a hotspot (MyHotspot) using Create New Wi-Fi Network... in order to share my wired connection with others via wifi, and now my laptop always automatically connects to the hotspot whenever I turn on the wifi.

I have tried to delete the hotspot both from Edit Connections... and by manually going in /etc/NetworkManager/system-connections and removing the hotspot with sudo rm MyHotspot. However, every time I turn on the wifi, for some reason, MyHotspot reappears and the laptop connects to it.

This is very annoying also because, for some reason, it also prevents me to use VPNs whilst connected with the wifi.

Any ideas on how to definitively get rid of the hotspot?

2

You should be able to delete the MyHotspot from Edit Connections. However, you can also disable the autoconnect by editing the MyHotspot profile, and unchecking the "Automatically connect to this network when it is available".

enter image description here

2
  • As I said in the post, deleting the connection from Edit Connections didn't work. Also unchecking the "Automatically connect to this network when it is available" box does not work.
    – Marce
    Mar 27 '17 at 8:22
  • @Marce Then, in terminal, cd /etc/NetworkManager, ls -al, and check that system-connections file mode is drwxr-xr-x, owner root:root. Then cd system-connections, ls -al, and check the file modes and they should all be -rw-------, owner root:root. If they're not, we'll have to chmod them.
    – heynnema
    Mar 27 '17 at 13:24
2

You can try to use

nmcli con show

then to make it stop autostarting and connecting

nmcli con mod <connection-name> connection.autoconnect no

This solved my problem atleast

-2

I’ve changed my hotspot password. I think that would disable any other devices or users that have connected in the past, not allowing connection unless I give them or enter the new password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.