0

I'm using Ubuntu 16.04.2 LTS.

When I need to disable the wifi, I usually click the network applet and remove the check from Enable Networking or Enable Wi-Fi.

The problem is, when I enable it again, all the wireless networks are gone from the applet. Ubuntu will connect to one network I have access but I won't able to see which one, neither will I be able to change to another network.

The only way to make the applet show them again is to reboot the system.

Any tips on how to make the applet to display the networks again without needing to reboot?

Any ideas if there is any workaround I might try to solve the problem?

Thanks!

2
  • When the applet starts misbehaving run systemctl restart network-manager.service
    – M. Becerra
    Mar 24 '17 at 11:57
  • Now, that's really cool! Solved the problem. Please add this as an answer and I'll mark it as answered Mar 24 '17 at 12:00
1

In order to restart the applet and the network service run:

systemctl restart network-manager.service
0

This is an old trick i have been using. Give it a try before you restart. The command turns off and on the networking

$ sudo nmcli nm enable false && sudo nmcli nm enable true

run it and let us know the feedback

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.