This is a bit confusing to explain but I will do my best. I recently upgraded from 16.04 to 16.10 and the behavior of my menu bar has changed slightly.

So before when I would click on a menu drop down option (lets say "File") it would drop down and give me a bunch of options. I could then hover over an adjacent drop down (lets say "Edit") and it would change the focus of the drop down menu. So just by hovering over "Edit" after I already had File open the "edit" drop down would display.

Since I upgraded I can open a menu fine by clicking on it but once it is open hovering over adjacent menu options no longer will automatically open it. I don't know if this was an intentional change with the upgrade but I prefer the original functionality.

If anyone knows how to change this back to it's original functionality it would be much appreciated.

enter image description here

Using the above image as an example, now that "File" is open when I hover over "Edit" I expect it to open automatically but it no longer does.

  • What interface are you using? Could you post a screenshot of the menu bar? – Muaad ElSharif Jun 1 '17 at 12:03
  • Is it the global menu bar (in Unity)? Try toggling /com/canonical/unity/always-show-menus from dconf-editor and see if that fixes your problem, it did for me. Possibly a Unity bug. – Jeremy J Wong Jun 1 '17 at 23:18

Okay, I think (hope, because it is an easy solution) that this is your problem: The Window Title shows, and the options to the right of it are always shown, or they are only shown when you hover over it. Either way can be fixed.

Go to System Settings(All Settings)

Click Appearance

Click the sub-menu Behavior

Under Menus Visibility, select and test both settings:

Displayed on mouse hovering
Always Displayed

I am pretty sure that this was your question, and I think that this solution is the same as toggling: /com/canonical/unity/always-show-menus from dconf-editor

Screen Shot Steps:


System Settings - Appearance


enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.