0

Starting today, every time my computer wakes up from hibernation I get a screen that looks like this:

enter image description here

Any idea what's going on? I tried some of the fixes mentioned here: Ubuntu 14.04 window problem after waking up from suspend, Blank screen after suspend/hibernate on 14.04

I also tried reinstalling the NVIDIA drivers, which did not work either. I'm on Ubunt 16.10 on a HP m7 notebook with NVIDIA GeForce 840M. Any help is appreciated.

EDIT: Screenshot of "Additional Drivers" GUI. enter image description here

  • It's a bug reported for some newer Nvidia drivers versions. It shouldn't happen if you use the drivers available at the official repositories. – user589808 Mar 24 '17 at 0:11
  • To reinstall the drivers, I just did "sudo apt-get install nvidia-current". That should work, right? – Alex Mar 24 '17 at 0:22
  • No, it shouldn't, unless you have legacy hardware."Current" is arguably misleading because it suggests the current version when in reality it installs the "current long term support" driver for legacy hardware as in the last driver you'll ever ever have for that old card. Not the case here. – user589808 Mar 24 '17 at 0:32
  • I see. How should I revert the driver then? – Alex Mar 24 '17 at 0:36
  • 1
    You are indeed (but you should also install the CPU microcode although not related). The bug has been reported with the 375 version and newer. 370 or 367 apparently don't produce this effect. – user589808 Mar 24 '17 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.