3

It seems shotwell has the capability, you just have to compile it. I tried to configure with --define=ENABLE_FACES but the feature isn't showing up. I used playya git which included a recent fix for a compile faces error.

| improve this question | | | | |
  • Try ./configure --help or the README – Panther Dec 21 '11 at 20:20
  • I tried that just now, yet even when I open shotwell the "Faces" icon doesn't appear at the bottom toolbar. – tupperware Dec 21 '11 at 20:51
  • If you compiled it with the proper configuration, where did you install it to ? /usr/local/bin ? If so, you may need to change your launcher or call it directly from the command line. If it is not working after you compile it, you should probably post on the shotwell mailing list or file a bug report (upstream). – Panther Dec 21 '11 at 21:12
  • Yeah I uninstalled the one from the software center and installed into /usr/local/bin, running shotwell from there via cmd line or nautilus doesn't seem to make a difference. The version that shows up in About is 11.90 Trunk so that's correct. – tupperware Dec 21 '11 at 21:25
  • 1
    If you would be so kind as to post the solution , the options you used to compile, and how to see the faces, that would be awesome. FWIW, when compiling, consider ./configure --prefix=/usr/local , then when you install, it will go to /usr/local. the benefits, you can keep your other version installed, easier to remove (it is in /usr/local), and it will not over write system files maintained by apt. – Panther Dec 21 '11 at 21:51
5

The Faces feature was #ifdef'd out of the source until Yorba could add a little more functionality to Shotwell to make it truly useful -- see Bugzilla - Upload faces to facebook and Bugzilla - Face detection. However, as we continued developing other features for Shotwell, the Faces code broke, so there's no way to build Shotwell with Faces support from trunk; see http://redmine.yorba.org/issues/4518

As you mentioned, a patch was made available at git://github.com/playya/shotwell.git. When I build and run Shotwell using this branch, I see the Faces feature and it appears to work. Here's how I did it:

$ git clone git://github.com/playya/shotwell.git shotwell-faces
$ cd shotwell-faces
$ ./configure --define=ENABLE_FACES
$ make
$ ./shotwell

It appears you can also use ./configure --enable-faces, but I tried the above way first and it appeared to work.

Note that you can run Shotwell directly from the build directory. However, to make it available on your desktop and integrate with Nautilus and so forth, you'll need to do this:

$ sudo make install

To see the Faces button, open a photo (double-click on it). It's only available in the photo editor.

Warning: This fork has not been reviewed by Yorba yet. We can make no promises when the Faces feature will be fully integrated into Shotwell. There are other risks using the playya fork, including losing the ability to upgrade your database later. I recommend backing up your database before using it: http://redmine.yorba.org/projects/shotwell/wiki/ShotwellFAQ#How-can-I-back-up-my-Shotwell-library

| improve this answer | | | | |
  • The last link is broken :( – linusg Sep 25 '16 at 7:13
  • See askubuntu.com/a/1145778/898365 (It is possible to use this feature when on the unstable branch of the Flatpak version of Shotwell, but it still has basically the same functionality since 2011 - it can only detect faces in one photograph at a time, and sometimes it might think your curtain or fridge is a face - but at least you have the ability to manually draw a box around a face, which is good progress.) – Riyaad Azad May 24 '19 at 3:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.