1

I am having issues with my recently built pc. The screen will freeze while doing anything, requiring me to perform a hard shutdown and reboot in order to end the problem. Trying to do CTRL + Shift + F1-7 doesn't work during a freeze either.

Digging through my syslogs, the only thing I could find that could be the issue is the error:

kernel: [   10.945208] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up

I am using the integrated graphics card of my CPU, since this computer is not for anything intensive such as gaming, but to be a Plex server.

  • My Motherboard is an ASRock H110-HDV LGA1151
  • My CPU is an Intel Core i5-6400 Skylake

I added those because I read some forum posts saying that using the integrated graphics is the issue, but I wasn't sure since the posted solutions did not work for me. My kernel is at 4.8.0.-41, which I believe is the latest version.

How can I fix this and end the random screen freezes? Thank you very much!

2

If you have Intel this may help you. I was having this same problem fairly frequently (3-4 times a day) and nothing I did including upgrading to the 4.8 kernel helped.

Then I found this:

Ubuntu 15.10 and 16.04 keep freezing randomly

Particularly the 1st answer provided the solution that worked for me as I no longer have these "freeze-ups" on my laptop.

= = = Quote of what worked for me = = =

However, this problem(where nothing but forced shutdown works to recover from the freeze) may be related to the kernel and if kernel upgrading cannot solve the problem, then an work-around could be to add the statement intel_idle.max_cstate=1 in the grub configuration file.

Before doing the following make a COPY of your current GRUB file so you can restore it if you happen to mistype something...

sudo nano /etc/default/grub

There is a line in that:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (like this)

replace with (all 1 line):

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"

Save it - (CTRL+O)

then..

sudo update-grub

sudo reboot

Since I've made this change I rarely have any more freeze-ups and if I do they only last for maybe 5-10 seconds then clear up.

  • This seemed to have fixed my issue! Thank you very much! – Power_Man_2017 Mar 24 '17 at 3:43
  • I wanted to inform you that the problem came back today. I didn't do anything different, but the screen started freezing again. – Power_Man_2017 Mar 27 '17 at 4:56
1

SOLVED after 7 months of HELL

goto "synaptic-settings-repositories-additional drivers" see if you have a "Unknown Unknown" radio button if you have then select it as i have in picture ,two weeks not one freeze.

enter image description here

0

Sounds like a kernel bug for this particular Intel chip.

My first suggestion would be to test the latest mainline kernel, to see if this issue is solved in the latest mainline kernel. This will help you when opening a bug: https://wiki.ubuntu.com/Kernel/MainlineBuilds

It seems this same error has occurred quite a bit mostly on Lenovo laptops. For example this bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1651454

However it's hard to say if they are really the same issue or not just from the error message. It seems at least some of the causes of this issue should have been fixed in 4.8.

Any which way most likely some kind of kernel patch will be required to fix it, so opening a bug report is the way to go. Please see here for instructions on opening X related bugs: https://wiki.ubuntu.com/X/Troubleshooting#Reporting_a_confirmed_X_bug_to_Launchpad

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.