I decided to switch to Ubuntu from mac os and it mostly works fine, but one problem appeared:

When I press 'Suspend' or close the lid of my macbook, the screen turns black (like it should) and after around 3-5 seconds the screen turns on again with the login screen.

I'm sorry if anyone already asked this question, but I didn't find a similar problem with a google search.

Edit: Model Number is A 1502 EMC 2835

  • 2
    as root run: dmidecode |grep -i macbook so we have more details about your specific hardware – tomodachi Mar 29 '17 at 17:47
  • 1
    @Arronical Please don't change the title when you haven't read my question yet. Everything was correct. link – Jeb Mar 31 '17 at 17:39
  • @tomodachi Here it is: Product Name: MacBookPro12,1 Family: MacBook Pro Version: MacBookPro12,1 – Jeb Mar 31 '17 at 17:45
  • Sorry @Jeb, looks like I was a bit hasty there! – Arronical Apr 1 '17 at 21:00
  • @Arronical In the end everything worked out, so no problem! – Jeb Apr 2 '17 at 22:27

You are effected by this bug which appears to effect kernels 4.2 - 4.4 I suggest that you subscribe to the bug so that you can be notified of progress and the developers have a better idea of the impact it's having. As touched on by this answer by user 1783630 According to the author of the bug a functional workaround is to Disable XHC1 prior to sleeping by issuing the command

echo XHC1 > /proc/acpi/wakeup

However, the current content of /proc/acpi/wakeup in my 16.04 system is a bit more complex than that consisting of 4 columns of info covering Device, S-state, status, and sysfs node so I'm not convinced this is the way to go with Ubuntu. The bug has already been confirmed and triaged so hopefully this will be resolved with a newer kernel.

Edit: This related question also has some good answers that you may be able to modify to fit your circumstances



  • 1
    Thanks you very much! You initial solution didn't work, because i needed to disable something else. The link you provided me helped. – Jeb Mar 31 '17 at 22:04
  • @Jeb I'm glad you got it sorted! – Elder Geek Mar 31 '17 at 22:15

From the Arch Wiki entry for your model:

It may be necessary to disable USB's wakeup ability by by echoing 'XHC1' to '/proc/acpi/wakeup' in order to prevent immediate wakeup on suspend.

Once you tried it, you can put the line into your /etc/rc.local file in order for it to be executed on every boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.