0

I have Ubuntu 14.04.4 LTS and PHP 5.5.9

When I try:

sudo apt-get install php5-pgsql

I get this error

Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies. linux-image-extra-3.13.0-106-generic : Depends: linux-image-3.13.0-106-generic but it is not going to be installed linux-image-generic : Depends: linux-image-3.13.0-106-generic but it is not going to be installed php5-pgsql : Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.21) but 5.5.9+dfsg-1ubuntu4.20 is to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I try

sudo apt-get -f install

and I get this

(Reading database ... 550803 files and directories currently installed.) Preparing to unpack .../linux-image-3.13.0-112-generic_3.13.0-112.159_amd64.deb ... Done. Unpacking linux-image-3.13.0-112-generic (3.13.0-112.159) ... dpkg: error processing archive /var/cache/apt/archives/linux-image-3.13.0-112-generic_3.13.0-112.159_amd64.deb (--unpack): cannot copy extracted data for './boot/vmlinuz-3.13.0-112-generic' to '/boot/vmlinuz-3.13.0-112-generic.dpkg-new': failed to write (No space left on device) No apport report written because the error message indicates a disk full error Examining /etc/kernel/postrm.d . run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.13.0-112-generic /boot/vmlinuz-3.13.0-112-generic run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.13.0-112-generic /boot/vmlinuz-3.13.0-112-generic Preparing to unpack .../linux-image-3.13.0-106-generic_3.13.0-106.153_amd64.deb ... Done. Unpacking linux-image-3.13.0-106-generic (3.13.0-106.153) ... dpkg: error processing archive /var/cache/apt/archives/linux-image-3.13.0-106-generic_3.13.0-106.153_amd64.deb (--unpack): cannot copy extracted data for './boot/System.map-3.13.0-106-generic' to '/boot/System.map-3.13.0-106-generic.dpkg-new': failed to write (No space left on device) No apport report written because the error message indicates a disk full error dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Examining /etc/kernel/postrm.d . run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.13.0-106-generic /boot/vmlinuz-3.13.0-106-generic run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.13.0-106-generic /boot/vmlinuz-3.13.0-106-generic Errors were encountered while processing: /var/cache/apt/archives/linux-image-3.13.0-112-generic_3.13.0-112.159_amd64.deb /var/cache/apt/archives/linux-image-3.13.0-106-generic_3.13.0-106.153_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

1 Answer 1

0
...cannot copy extracted data for './boot/vmlinuz-3.13.0-112-generic' to '/boot/vmlinuz-3.13.0-112-generic.dpkg-new': failed to write (No space left on device)...

You have to free some space.

(Im on the phone atm, I'll edit the answer later to add further info)

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .