3

This question already has an answer here:

I had Windows 10 installed along Ubuntu, and would choose from grub loader.

I later uninstalled Win 10 and installed Win 7 in its place, I updated grub in Ubuntu but the Windows 10 entry in grub did not go away.

I now have two entries, both entitled Windows 10, one in /dev/sda1 and the other in /dev/sda2.

Both load Windows 7, but not on the first try. When I initially load it, the screen is dark, while Windows has loaded in the background (I can hear the sounds).

I have to power-off the computer, then choose Windows again for the screen to work. Sometimes I have to repeat this more than once.

I don't know much in Linux so I can't tell if the problem is from Windows or grub.

marked as duplicate by Android Dev, 2707974, Community Apr 4 '17 at 9:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    You ran sudo update-grub from Ubuntu? Also, is Ubuntu installed in UEFI mode? – Android Dev Mar 22 '17 at 18:54
  • @AndroidDev Yes. Do you mean which 'mode I have in BIOS? I think it's legacy. – MichaelX Mar 22 '17 at 19:05
  • Usually Windows makes some other partitions alongside the main partition during the installation. Did you remove those partitions before installing Windows 7? – Dante Mar 27 '17 at 13:23
  • @Dante I fixed the issue, I'm not sure what exactly fixed it. I disabled the graphic terminal from grub /etc/default/grub .Grub detected Win 7 this time, I don't know why it didn't detect it the first time I updated it. Maybe the graphics terminal option fixed it, maybe it wasn't relevant at all. – MichaelX Mar 27 '17 at 16:24
  • 3
    Possible duplicate: askubuntu.com/a/536757/625501 – fossfreedom Mar 29 '17 at 8:11
1
+50

This question is a duplicate of GRUB2: black screen when booting Windows but cannot be closed due to bounty rules. The solution as confirmed by OP in comments is:

sudo gedit /etc/default/grub

Search for the following and change the second line to look like:

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

Save and exit then run:

sudo update-grub
0

The terminal option isn't relevant.

If you've run sudo update-grub and the results are inconsistent, That points to a hardware problem with the storage media. I highly recommend that you check the status of your /dev/sda drive as you may have failing sectors buried under the MBR or under your /boot/grub/grub.cfg file.

Not the answer you're looking for? Browse other questions tagged or ask your own question.