12

I know that this is quiet weird question and the problem might not look big but it's annoying after all. I use 2 monitors and when I try to move mouse to the other monitor it usually gets stuck at the edge. In order to move mouse to the other monitor you have to move mouse very quickly. In windows however this transition is much smoother where you can move the mouse slowly but still move it to the next monitor and it feels like you are using 1 monitor. Is there a way to fix this?

9 Answers 9

11

This seems to be the "Sticky edges" which are activated in Ubuntu by default. Go to the System Settings, choose Screen Display and deactivate "Sticky edges".

3
  • This is exactly what my problem is. Thank you very much.
    – Vsky
    Mar 22, 2017 at 16:45
  • Is this option still there for 18.04? Couldn't seem to find it.
    – liang
    Aug 18, 2019 at 2:36
  • 2
    Yes, unfortunately not in the usual settings GUI. It is described here: askubuntu.com/questions/907797/… Easiest is to run gsettings set org.gnome.shell.overrides edge-tiling false in console. Aug 19, 2019 at 15:18
3

Search menu for Displays

or

Go to menu > Settings > Displays

and Set Sticky Edges to OFF

enter image description here

1

Couldn't find any sticky option setting in Kubuntu 19, however I found that there was an small gap between the monitors in the displays settings. Once I re-placed them so they were aligned to each other, the annoying cursor-push to move across was gone

1

As reported here this problem is related to "auto hide the dock".

So, a workaround is disable dock on second monitor, or disable auto hide the dock.

To disable the dock on second monitor one can do as suggested by pomsky:

$ gsettings set org.gnome.shell.extensions.dash-to-dock multi-monitor false
1

I got other solution. Just to give some context, i have 4 screens like shown in the picture and i had problems changing from the top one to the bottom middle one. To solve this without removing the dock from the other screens, i went to dash to dock settings, intelligent autohide settings and disabled push to show.

1

I have Ubuntu 22.04. I could not find the sticky edges option.

What worked for me was to disable the dock from the second monitor. That fixed my sticky mouse behavior.

0

In my experience this problem occurred because of dock on secondary display. Go to Settings / Dock / Show on/ and from drop down menu choose Built-In-Display.

0

It's because of different screen size on my monitors. Moving the second one in the middle of the side edge of the main one solved problem. It's only top and bottom corner left to stuck of the mouse cursor, but it's fine for me.

0

Move the dock so that it is not on the edge between your monitors.

Moving the dock to the left of the left monitor, or to the right of the right monitor, etc...

You may need to move the dock to the other monitor based on your preference. Just set the other monitor to primary if needed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .