0

I am trying to dual boot Ubuntu 16.04.2 LTS and windows 10 on Dell XPS 13 (9350) laptop. Windows 10 came pre-installed and I am installing Ubuntu via bootable USB stick using Rufus.

I have tried both the "install alongside Windows option" and manual configuration as well, In both cases it installs more than halfway, then prompts the error:

Unable to install GRUB in /dev/nvme0n1
Executing 'grub-install /dev/nvme0n1 failed
This is a fatal error

Installlation and Error

I have the following configurations set in BIOS (Version: Dell Inc. 1.4.13, 28-Dec-16)

UEFI Boot, Enable UEFI Network Stack, AHCI, Secure Boot disabled.

BIOS Config

Any help would be greatly appreciated. Thank you!

  • I have tried the following solutions so far and none of them worked for :( First Second – shahidj Mar 22 '17 at 14:26
0

Try this:

  1. Download the USB flash drive or CD-R version of my rEFInd boot manager. (Download links for both are on that page.)
  2. Prepare a boot medium from that.
  3. Boot with the rEFInd disk. You should see the rEFInd menu appear, with options to boot both Windows and Ubuntu.
  4. Test both boot options.
  5. If both boot options (Windows and Ubuntu) work, boot to Ubuntu.
  6. Install either GRUB 2 or rEFInd....
    • You should be able to install GRUB 2 by installing the grub-efi package and then running sudo grub-install, possibly followed by sudo update-grub. This procedure is a bit of a shot in the dark, though, and the installer should be doing basically this, so there's a good chance this won't work -- or at least, you may need to intervene with tricky custom configuration.
    • You can install rEFInd using the Debian package or PPA. This should work automatically, but if it fails, you might need to follow the manual installation instructions.

FWIW, I've been seeing a number of reports of problems like this. There are this bug might or might not be the issue in your specific case. I've seen other bug reports, but most of them have been marked "invalid" because of misconfiguration of the target system. It's also possible that this is the root cause of your problem, but I can't be sure of that. If the preceding procedure doesn't help, please run the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. This will give us more details about your configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.