1

I have recently installed Ubuntu 16.10.

I frequently see screen flickering, but only when I open the terminal and run some commands, not when I use browsers or at any other time. When I press keyboard keys to type commands in the terminal I see flickers and after some time my entire screen goes blank, (but my laptop does not switch off) and I then have to force shut down every time. This problem does not happen when i am working on windows.

My graphics driver is Intel corporation core processor integrated graphics controller

2

I oserved the same thing using Ubuntu 16.04 and 17.04. Changing the desktop environment did not help. I tested Gnome3, gnome-flashback, mate...

I am able to reproduce the issue with gnome-terminal, xterm, and also gedit. I am not able to reproduce it with libre-office writer, firefox (google search input line).

The problem occours much more often when key presses are combined with simultaniously moving the mouse cursor.

I fixed the problem by changing accelerate mode from SNA back to UXA:

Create a file /etc/X11/xorg.conf with the following content:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option     "AccelMethod"  "uxa"
EndSection

Hope that helps

  • 1
    Nowadays the recommended location for xorg configs is a file in /usr/share/X11/xorg.conf.d/, which is - when done right - less prone to unintended side-effects. – anx Oct 8 '17 at 14:59

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.