Note that this is Kubuntu (KDE Ubuntu)

I've been having a problem for a while where if I turn on the computer, it just takes me to a black screen. It sticks there with no output and no hint of what's going on except that the Caps Lock indicator light on my keyboard flashes on and off (weird, right?)

If I then turn off the computer (by holding down the power button for a few seconds), and turn it back on, I get a boot menu where I can choose 'Advanced options for Ubuntu', and that lists different versions, recovery modes, some of which work just fine.

That's what I've bee doing for the two weeks or so I've had this problem, and it worked until just now. The alternative options only booted me into the command line. I was able to fix this with this solution, so now I'm typing this from my desktop.

I'm reluctant to turn off the computer in case it happens again, and I'd like to just tear out the root of the problem.

Screenshot of error: enter image description here

  • 1
    Caps lock blinking is a sign of kernel panic -- fatal crash of the Linux that runs Ubuntu. Try opening /etc/default/grub with a text editor as root and change GRUB_CMDLINE_LINUX_DEFAULT="splash quiet" to GRUB_CMDLINE_LINUX_DEFAULT="nosplash debug --verbose". That way you can see exactly what's causing the panic during boot. Then run in terminal sudo update-grub and shut it off. When you turn it back on you should see messages about everything the kernel is doing. See what errors you get just before the crash.
    – darksky
    Mar 22 '17 at 1:28
  • Something about mounting the filesystem: imgur.com/VvPLO88
    – Grund
    Mar 22 '17 at 1:59

It seems someone has been able to solve this issue here

Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

They suggest running

sudo update-initramfs -u -k $(uname -r)


sudo update-grub
  • $ sudo update-initramfs -u -k all update-initramfs: Generating /boot/initrd.img-version WARNING: missing /lib/modules/version Ensure all necessary drivers are built into the linux image! depmod: ERROR: Bad version passed version depmod: ERROR: Bad version passed version gzip: stdout: No space left on device E: mkinitramfs failure cpio 141 gzip 1 update-initramfs: failed for /boot/initrd.img-version with 1.
    – Grund
    Mar 22 '17 at 3:23
  • According to update-initramfs manual version is "the specific kernel version for whom the initramfs will be generated. For example the output of uname -r for your currently running kernel." I've updated my post. You should use the version of kernel that will be running your KUbuntu. It looks something like 3.5.0-47-generic. Also, it is telling you No space left on device. So the partition that holds your Linux images might be out of space.
    – darksky
    Mar 22 '17 at 5:43
  • @Grund - That means your boot partition is full.
    – Skudd
    Oct 1 '20 at 4:01

Thanks for this. It also help me when I tried to add nvme_core.default_ps_max_latency_us=0 to grub to fix a Kingston A2000 issue. After sudo update-grub nothing worked anymore till I found this help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.