0

Iam trying to install Discourse via Docker on my local machine.

I clone discourse docker to my folder:

git clone https://github.com/SamSaffron/discourse_docker.git discourse

then I ran

sudo ./launcher

to download the docker image. Now Iam confused what to do. I tried to start

sudo ./discourse-setup

but it stopped because I have an apache running on port 80:

Port 80 appears to already be in use.

If you are trying to run Discourse simultaneously with another web
server like Apache or nginx, you will need to bind to a different port

See https://meta.discourse.org/t/17247

If you are reconfiguring an already-configured Discourse, use 

./launcher stop app

to stop Discourse before you reconfigure it and try again.

So Iam told to lookup this page https://meta.discourse.org/t/17247, and there I read:

If you want to run other websites on the same machine as Discourse, you need to set up an extra NGINX proxy in front of the Docker container.

Do I really need to install nginx now? I thought, I can just bind a docker container to a specific port?! And Iam confused why I had to git clone this repo, shouldn't that all be placed inside the docker image?

edit: because of the first answer, I cheated in the setup file and changed the port (line 230). But that only passed the check, didnt change anything and leads to this error after running some time:

/usr/bin/docker: Error response from daemon: driver failed programming external connectivity on endpoint app (c4af1d602e59c05b2d5bdb1de59aab89e6b591c6fb26ceebb18f0a0dc4abbf6d): Error starting userland proxy: listen tcp 0.0.0.0:80: listen: address already in use.

0

I am not able to fully test this right now, but in theory if you change line 230 in discourse-setup file from check_port "80" to a free port, then it should work fine according to this post

| improve this answer | |
  • unfortunately thats only cosmetic (updated question) – user577728 Mar 22 '17 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy