5

I am trying to configure the i915 driver on my XPS 13 (9360) running Ubuntu 16.04 for better battery runtime.

I have created a kernel config file with this name:

/etc/modprobe.d/i915.conf

Content of the file:

options i915 modeset=1 enable_rc6=1 enable_fbc=1 enable_guc_loading=1 enable_guc_submission=1 enable_huc=1 enable_psr=1 disable_power_well=0

I have restarted the machine and checked the driver parameters with this:

systool -v -m i915

This doesn't list my options in the "Parameters" section.

Seems like my options are not set to the driver at all (only the "enable_hangcheck" option with its "Y" default value).

What am I doing wrong?

4
  • 2
    Try this command update-initramfs -u -k all I think it must help you. – Denis Mar 24 '17 at 19:08
  • 1
    May be try to add this to kernel parameters via grub in such form: i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1. – Denis Mar 25 '17 at 10:15
  • 1
    Or try this instruction feeding.cloud.geek.nz/posts/… – Denis Mar 25 '17 at 11:10
  • the systool cmd will report actual settings only if you type it as root (as lambda user, you get indeed only one parameter reported) – Joan Moreau Jun 13 '17 at 5:50
5

The solution was to regenerate the boot images with update-initramfs (thanks Denis).

For all kernels (if you have more than one installed)

update-initramfs -u -k all

For the currently used kernel (if you don't want to touch the others)

update-initramfs -u

After this, the options were set because I saw a boot-time error about "enable_huc" parameter being invalid (dmesg). However, systool still doesn't show the options.

1

I created /usr/share/X11/xorg.conf.d/20-intel.conf, see also

man intel

#/usr/share/X11/xorg.conf.d/20-intel.conf
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

And now I have a decent background.

Not the answer you're looking for? Browse other questions tagged or ask your own question.