Okay, before you guys say it's been answered and besiege me with links, I promise I've spent a TON of time searching: honestly I've looked, I've tried everything on every post I've found. I hopped in the IRC channel and the few times I've asked for help on it, people have said either that theirs works, and didn't seem interested in helping or other terse responses that "flash will be dead soon anyway, just wait.", which I can't wait till it is, but I can't "just wait".

I've tried in Firefox, Chromium, & Chrome all to not avail. I'm aware that Firefox can now get Flash v25 starting back in 49 (i think?). I've got 52 installed and can't for the life of me get DRM playback.

EDIT: I can only post two links as I don't have enough rep yet. Apologies but they'll be in follow up posts. If you don't mind, I'm going to start by posting the sites I've tried (and failed) to get working along with my "symptoms" followed by the many ways I have tried to get it working. Assume they don't work in both browsers unless notated.


WatchESPN - (Seemingly won't let me click on anything, sometimes one pops up and I usually get an endless loading circle, sometimes I get error 302 (some links I've found say uBlock causes it, even with it entirely removed I still get it). One or two times I've been able to get an "alternate" feed, SkyCam, Spanish broadcast, etc. but my guess is they werent' DRM protected.

FoxSportsGo - Endless loading without controls

NBCSports - Endless loading without controls

BeinSportsConnect - Endless loading. They use Silverlight IIRC, so a bit different as far as ways to go at it.

HBOGo - Black screen on whatever I click to play. It does give me the controls - play, pause, volume, etc.

Showtime Anytime - Endless loading circle for 15 seconds or so, then kicks me back to the episode selection.

Now, I've tried quite a few different ways of getting this to work, all with no positive outcome.

Once installing (to be clear, reinstalling) Firefox (v52) I saw an old adobe article mentioning installing hal (although it is currently dead as far as current OS's go) and I seem to remember seeing another old article where someone mentioned that once they installed the "zombie" hal/hal-flash ppas from mjblenner and Martin Wimpress, the skies parted and all was well. So I figured I'd try it, no dice so I just moved on.

What I found seemed to suggest that now with Flash being supported outside of Chrome that I shouldn't be running into the issues that I am. Finally I figured that I must be missing something and talking with someone in relative real time would be the best course of action. I hopped on IRC and was told by quite a few people that they hadn't had any issues with WatchESPN or other DRM enabled streaming sites. None of them seemed interested in assisting me so I went back to searching and trying anything I could find that might make it work.

Before I went back on search engines, I uninstalled Flash and ran an apt-get purge of chrome & firefox, then went into my home directory and flat out deleted the .adobe folder, .mozilla folder, the .config/google-chrome folder. I got rid of the freshwrapper-data folder and deleted: /usr/lib/mozilla, /usr/lib/firefox, & /usr/lib/firefox-addons thinking that every possible thread was gone and upon new installs everything would work just fine. Obviously I was wrong or I wouldn't be here posing the question.

As far as pipelight goes I saw here that it was being tested in Firefox Nightly and I have the ppa for it added, but I'm not sure if I needed to install it to try and get the Silverlight associated sites to work now that DRM is supported again in Firefox. I tried it anyway, but didn't work.

Most of the articles/posts/questions I have read seem to be at least a year old, most of them more so, but some seem to have had at least SOME activity more recently. These are the somewhat newer ones I've tried and not gotten to work.

HTML5 DRM video won't play on Ubuntu 15.10 with latest Google-Chrome - while including DRM doesn't EXACTLY relate to this

Not interested in installing Wine. I'll do a VM if it comes to that.

itsfoss.com article - I guess Christmas 2015 isn't THAT new.

There are plenty of others that had different steps of adding the hal ppas, then freshplayer, the new firefox or other things I've listed here.

Please Obi Wan Kenobi.. Oops, wrong closing.

Please guys I'm going mad at this. Any help is GREATLY appreciated. I really need the sports sites to be up and running as I'm tired of resorting to pirated streams to watch the games I want to; especially when I pay a fee for these sites that I can't get working. I've been on Linux over a decade. I have my iMac showing one game, but that's too few.

If you've made it this far, thanks for taking the time to read this long post/question. I really do appreciate it.


4 Answers 4


Unfortunately I don't think it is currently possible (as of March 2017) to natively watch any of these in linux without exposing your system to security vulnerabilities, since they required the hal-flash package with flash 11.*, and this no longer works in more recent flash versions.

One workaround that I have used to watch HBOGo (with somewhat limited success) is to run android-x86 in virtualbox and use their app. Another potential workaround is to downgrade to flash 11.* in firefox and install hal-flash, but running an out of date flash plugin is a tremendous security risk (and recent versions of firefox will block it by default because it is out of date) and there is likely no simple way to do this through regular software channels on ubuntu or most other distros.

Sources: https://github.com/cshorler/hal-flash/issues/26 for a discussion on this exact issue.

From adobe's announcement itself it seems possible that this will never work again in the NPAPI flash plugin: "Because this change is primarily a security initiative, some features (like GPU 3D acceleration and premium video DRM) will not be fully implemented." https://blogs.adobe.com/flashplayer/2016/08/beta-news-flash-player-npapi-for-linux.html (they seem to imply that DRM works on PPAPI flash, but this is unfortunately also not the case as these sites have never worked with chrome's flash).

  • Awesome. Glad to know I wasn't just going mad with the routes I was trying. I'd rather avoid setting up a VM just to stream stuff (as that's ALL I'd use it for). I believe I'll try installing an old version of flash in a browser that I solely use for that purpose (iceweasel, an old version of firefox, something of that sort in a restrictive permissions directory). Thanks very much @Aristocrates I may end up coming back to you for some help getting it all working, haha. :D Apr 1, 2017 at 6:43
  • According to updates on the thread at github.com/cshorler/hal-flash/issues/26, drm seems to be working on ChromeOS flash, and some commenters claim that it can be extracted and used natively in recent versions of firefox
    – Nick Meyer
    Sep 6, 2017 at 5:40

Thanks to everyone for this detailed post about this matter. It seems that as of March 2018 there is no solution for read DRM and Flash contents - ie HBO Go in my case. I tried everything with my ubuntu 16.04 , hal ... hbo still resist.

It seems that Firefox clearly says that Flash and DRM is not supported.


  • You can set this as solution then. Mar 1, 2018 at 18:57

I have been scratching my head over this for too long now, and finally managed to make it work with the ChromeOS version of flashplugin with Chromium browser.

Check this discussion on Ubuntu Forums on steps to extract the libpepflashplayer.so from ChromeOS recovery image:

The extracted flashplugin should support DRM, and can be verified by this:

strings -a libpepflashplayer.so | grep PPB_Flash_DRM

If you get something like this in the output, know that it supports DRM:


(The bundled libpepflashplayer.so from Chrome shouldn't return anything)

You can then run an instance of Chromium with this extracted file as follows:

$ chromium-browser --ppapi-flash-path=<path to the extracted file>/libpepflashplayer.so

It may complain about flash player being outdated. I just ignore it, and it works fine.

(PS: It should work on Firefox as well if you install freshplayerplugin and make it use the extracted version of pepper flash)

  • This problem still seems to plague the Linux versions of libpepflashplayer.so, as unless you can get your hands on a ChromiumOS version, the PPB_Flash_DRM flags are missing. I've tried the above steps on Chrome 64.0 and they don't seem to work. Interestingly enough, when trying a dated DRM enabled version (e.g., Chrome still lists the active version as the latest (e.g. Overwriting the file inside ~/.config/google-chrome/PepperFlash/ seems to throw a version mismatch. Does anyone have this working on Chrome 64 or higher?
    – tresf
    Feb 18, 2018 at 3:38
  • Disregard, I seem to have obtained an ARM build of the file. I'll try again with an Intel x86_64 version. libpepflashplayer.so: ELF 32-bit LSB shared object, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3
    – tresf
    Feb 18, 2018 at 4:19
  • So I got further... I managed to get the DRM-enabled plugin from ChromeOS, but the system throws device_id_fetcher.cc(143)] Empty machine id using the test page from Adobe, Ubuntu 16.04 github.com/i-rinat/freshplayerplugin/files/1734418/…
    – tresf
    Feb 18, 2018 at 5:23

I've installed Firefox on a 32 bit Wineprefix. For flash I've been using the offline installer here: https://fpdownload.macromedia.com/pub/flashplayer/latest/help/install_flash_player.exe So far it works fine.

  • Thanks for the tip @MK but I was looking for a fix that didn't deal with WINE. I do appreciate the idea though! May 25, 2017 at 22:16
  • If Firefox gets access to DRM why not Chromium? Both are "community" projects, right? I'm using Chromium for browsing/blogging but must switch to Firefox for online TV. Bumma... There's got to be an easy fix for newbs like me. (?)
    – earthpages
    Mar 4, 2020 at 16:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .