19

I have problem with my HDA Intel PCH audio under Ubuntu 16.04. I never had any problem with speakers, however my microphone is not working.

When I plug microphone in jack, system reacts and it looks like microphone is in, however no single bar appear in any settings in "Input levels". The microphone works fine, just tested on notebook with Ubuntu 12.04.

Screenshot

Here is my info

  • did you solve your problem ?? im having the same issue! – lotfio May 11 '17 at 14:57
14

I had this exact problem. My solution:

1) open PulseAudio control

2)go to the configuration tab.

3)select analog stereo duplex to use the computers built in audio&mic

enter image description here

| improve this answer | |
  • 1
    I've found that even though my setting was Analog Stereo Duplex, switching to another setting and then back to duplex solves the problem. – MHT Nov 13 '17 at 2:26
  • anyway to make it switch to microfone automatically? This one works but seems we have to change the output manually everytime – Breno Salgado Jan 24 '18 at 17:34
  • This did not fix it for me – HackerBoss Feb 15 at 17:45
7

Maybe this will work. Please reply to see if this is specific to that laptop or not.

https://askubuntu.com/a/824806/47206

https://unix.stackexchange.com/a/358989/32012

sudo apt-get install alsa-tools-gui

Then launch

hdajackretask

Then:

Check 'Show unconnected pins'

Check override pin 0x12 to internal mic.

Apply and test. Be sure that the mic level is high enough in sound settings (pavucontrol, etc)

If it worked 'Install boot override'.

enter image description here

| improve this answer | |
  • im having the same problem and this answed didnt solve it ?? any other solutions – lotfio May 11 '17 at 14:59
  • @ForDev - what laptop do you have? Do you see your mic in audio settings or in pavucontrol under Input Devices tab? If not, under Configuration tab: be sure you have selected ''Analog Stereo Duplex". – user47206 May 12 '17 at 12:46
  • thnx for replay i have just switched to debian and everything is working fine thnx :) i try all the solutions but didnt work for me i think the problem mybe comes from the updates because before everything was working fine – lotfio May 12 '17 at 15:29
  • @ForDev - you mean this was fixed with Debian rolling? What kernel version please? Maybe I'll stumble into this in the future on that Asus and using a newer kernel may be the way to go. – user47206 May 13 '17 at 10:16
  • When I try to apply changes I get this error: pa_stream_writablee_size() failed: Connection terminated – hellocatfood Oct 11 '17 at 16:11
6

My issue was a small variation to OP's problem - I have a headset (combined stereo headphones and mic) jack.

First use hdajackretask check that the problem is not related to the jack (eg see user47206's solution). For me, my jack was correctly detected as 'Headphone'.

  1. Press Ctrl+Alt+t to access the terminal.
  2. Type cat /proc/asound/card*/codec* | grep Codec in the terminal and take note of the codecs listed.
  3. If there are multiple codecs listed, determine which one relates to your headset jack. For me there were two listed - one related the the video card (Codec: ATI R6xx HDMI) and another related to the sound card (Codec: Realtek ALC3861). In my case, I was interested in the sound card because I was connecting to the PC headset jack and not a HDMI device such as a PC monitor.
  4. Look up the HD-Audio model for your codec in HD-Audio Codec-Specific Models. For my headset jack, the best fit was the dell-headset-multi model.
  5. Type cd /etc/modprobe.d/ in the terminal.
  6. Type sudo cp alsa-base.conf alsa-base.conf.bak to backup the file before editing.
  7. Type gksudo gedit ./alsa-base.conf to edit the file.
  8. Insert this line at the bottom of the file options snd-hda-intel model={HD-Audio model for you codec}. For example, for it me it was options snd-hda-intel model=dell-headset-multi.
  9. Save file and reboot.
| improve this answer | |
  • Thank you, this worked for me (aspire-headset-mic model). – Razem Jul 13 '19 at 14:06
3

I did it guys!

  1. sudo gedit /etc/modprobe.d/alsa-base.conf
  2. Look for the options snd-usb-audio index=-2 and change it to options snd-usb-audio index=0
  3. Add options snd-hda-intel model=auto
| improve this answer | |
  • unfortunately this did not work on ubuntu 19.1 + acer swift 3 :( looks like this was my last option. – FlyingZebra1 Mar 10 at 3:56
2

I had a similar issue and tried every answer I found online with no luck. Finally, from alsamixer I changed the Channel option which was 6ch, to 4ch or 2ch, and the mic started capturing input, don't know why...

| improve this answer | |
2

Very easy solution.

Screenshot

tl;dr : press red volume icon as shown in screenshot image above.

I had the same problem. On Ubuntu 16.04.3 LTS, KDE

My solution:

1) Go to "Audio Volume Settings"

2) Select "Input Devices" (Tab)

** in the top right corner the sound icon is marked in red. As mute.

3) Press (left click) the red sound Icon (mentioned above)

4) Press OK

Check if problem is solved.

If not make sure to choose the right option from the port options in the Input Devices Tab (I choose Internal Microphone) and make sure the volume percentage is above 0%, preferably for the test set to 100%.

It was the internal microphone on my laptop. Meaning the built-in mic in my laptop.

| improve this answer | |
0

Context: My headset audio was fine and the internal mic was also working. The only problem was with the headset microphone. It was not detecting. After the following steps, it worked again.

Few steps I tried: 1. Open the HDAJackRetask application. You need to install it if you have not. 2. Choose different codecs and choose Show unconnected pins. enter image description here

  1. In pin ID: 0x18, click override, and select Headphone from the dropdown.
  2. Click Apply now and Install boot override.
  3. Hit sudo also force-reload in the terminal.
  4. Restart your PC.
  5. Now again open the HDAJackRetask application and toggle the override option for pin ID: 0x18 to off.
  6. Click Apply now and Install boot override. It worked after this step. If not, try restarting the computer.

I cannot assure it will work for everyone though. :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.