0

Fresh install of Xubuntu 16.04.2. Everything seems correct, but all the Libreoffice menus are in the wrong language. I've checked - locale is correctly set (en_GB.UTF8), and other GUI applications are coming up correctly in English.

I found that some of the support files I'd normally expect for UK use were not installed (hunspell-en, the UK hyphenation support, the normal en_GB language support. Adding them in makes no difference at all - menus are still in the wrong language (no idea what it is - could be Arabic, characters are not the normal alphabet I would expect...).

As another attempt at a fix, I copied the ~/.config/libreoffice files from another Xubuntu 16.04 install (in which Libreoffice is using the selected English menus). Still no change.

Has anyone else seen this sort of problem, and (hopefully!) have suggestions as to how to fix it? I've done some searching but so far I've not found anything that matches this rather peculiar fault.

Any help gratefully accepted...

I've added a screenshot showing the language selection menu. If someone can identify the language and tell me how to select English, it would be a bit help. Seems odd that the heading is in English, but the rest isn't.

http://imgur.com/a/FTw2N

  • Just to confirm, the setting within LibreOffice are correct? Tools -> Options -> Language Settings? What if you change them to English (US)? Also, are your OS's regional settings correct? – Dorian Mar 21 '17 at 17:22
  • The OS regional settings are correct. The settings in LibreOffice aren't - if English is offered, I can't select it because I don't understand the offered options. I'd attach a screen shot, but I don't see an option to do so.... – toothandnail Mar 22 '17 at 14:04
  • Ok, and please post the exact version of LibreOffice you're using. We can then figure out where to click by comparing to an English version (ie, click the 4th menu item etc...) and navigate to the language options. – Dorian Mar 22 '17 at 14:15
  • Not a problem getting to the language settings. Trouble is, I can't read any of the language options in the pull-down menu. I'll have to try and get an image uploaded - maybe someone will recognise the alphabet and can point me in the right direction to select English.... – toothandnail Mar 23 '17 at 14:47
  • That would be helpful. Otherwise, you'll have to go through each one, one at a time. – Dorian Mar 23 '17 at 14:52

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.