This is my configuration:

$ inxi -b
System:    Host: balrog Kernel: 4.8.0-42-generic x86_64 (64 bit) Desktop: KDE Plasma 5.5.5
           Distro: Ubuntu 16.04 xenial
Machine:   System: Dell (portable) product: Latitude E4310 v: 0001
           Mobo: Dell model: 0D8H24 v: A00 Bios: Dell v: A14 date: 12/05/2013
CPU:       Dual core Intel Core i5 M 560 (-HT-MCP-) speed/max: 1199/2667 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: [email protected]
           GLX Renderer: Mesa DRI Intel Ironlake Mobile GLX Version: 2.1 Mesa 12.0.6
Network:   Card-1: Intel 82577LM Gigabit Network Connection driver: e1000e
           Card-2: Intel Centrino Advanced-N 6200 driver: iwlwifi
Drives:    HDD Total Size: 256.1GB (27.4% used)
Info:      Processes: 253 Uptime: 50 min Memory: 2115.3/7780.9MB Client: Shell (bash) inxi: 2.2.35

I run Kubuntu 16.04 on a Latitude E4310.

I got some issues with display windows refresh. I checked some resources on the internet and decided to apply the Ubuntu LTS Enablement Stack to upgrade my kernel from 4.4.x to 4.8.x.

This seemed to solve my initial problem. Great.

Actually, it seems it brought some regressions too (not sure they are all linked to this).

  1. Buttons display in LibreOffice are readable anymore (several layers mixed together).

  2. Cells selection in LibreOffice Calc is now invisible.

  3. I get kernel messages and flickering screen when I work on my terminal (yakuake or Konsole), and after several issues like this, my X freezes and I need to rebobot. This is not really predictable.

The last one is the most important issue. This is the error message in dmesg:

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
[drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder B FIFO underrun

Note regarding similar issues on this forum :

  • No problem when I boot the computer.
  • No problem when I unlock the system.

I found some more or less similar issues on Arch forum, but I guess that Xorg is not managed the same way in Kubuntu 16.04.

Note: I applied the same Ubuntu LTS Enablement Stack on my desktop without this issue.

3 Answers 3


I know the question is over 2 years old, but I got the same issues recently with i915 graphics driver, running Pop OS 19.04 (Ubuntu based distro). As of hardware, I have Intel UHD 620 integrated GPU, and for CPU, i5 8350U unit. What helped me with flickering was to set the i915 kernel parameters in /etc/default/grub

Search for this line and extend the value with i915 prefixed params as below: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_psr=0 i915.edp_vswing=2"

and reboot to see changes.

See the issue described sparsely in docs: https://wiki.archlinux.org/index.php/intel_graphics#Screen_flickering

It seems that setting edp_vswing=2 helped me the most with flickering. It sets voltage swing table to default 400mV, see more here: https://gist.github.com/Brainiarc7/aa43570f512906e882ad6cdd835efe57

I also bumped linux kernel to newest 5.3, just picked debs from PPA and dpkg installed them. But it's really mostly about setting this voltage in my case.

This also may help You: https://www.dedoimedo.com/computers/intel-microcode-atomic-update.html

Sorry for late response, hopefully it helps someone fixing the issues.

Update: I still had flickering after applying all these fixes, rarely, but still they occured.

What helped me was to update BIOS to latest (Dell Latitude 5490, current BIOS is 1.10.1), run diagnostics on startup and switch in BIOS from AHCI to RAID ON in disks configuration. So far no flickering at all. I'll update the post with results after a couple of days.

Update 2nd: Recently, I stumbled upon the very same issue during PopOS 20 beta testing. I managed to fix this issue by disabling CPU c-states in BIOS. Read more about it here: https://www.dell.com/support/kbdoc/en-us/000060621/what-is-the-c-state

This alone fixed the screen black flickering issue, until kernel is patched, I'd suggest You doing this.


I found a pretty logical workaround : the rollback.

I followed the below tutoriel:


The first part of the removal process actually removes xorg and kubuntu-desktop. We have to remember to reinstall them right after.

After that, I rebooted. It seems that the system kept one 4.8.x kernel by default, but it replaced the graphical stack with the previous one.

This solved the issue I got with LibreOffice (selections and buttons). It seems that it also solved the kernel CPU pipe issue.

Right now, I don't think I am going to dig this deeper.

Note : I am still with the new graphical stck and 4.8.x kernel on my desktop and it works well.



This seems to be a recurrent compatibility problem of some kernels with intel drivers. Eventually with the time the issue should be solved by the community and the Ubuntu team.

In the meanwhile, according to this link one possible workaround is to add this parameter to the command line of your kernel startup:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .