3

I installed a new partition in my PC with ubuntu 14.04 with lowlatency kernel: uname -a: 3.19.0-61-lowlatency #69~14.04.1-Ubuntu SMP PREEMPT Thu Jun 9 10:15:00 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

The wifi card works and is recognizable at the other partition and even in the normal kernel, but with lowlatency kernel:

rfkill list: 0:hcio: Bluetooth soft blocked: no Hard blocked: no without giving the wifi informations.

Ps: I can't connect my computer to Internet via Ethernet.

And the wlan0 config gives: wlan0: error fetching interface information: Device not found.

I tryied to add the wlan0 interface on the interfaces files: auto wlan0 iface wlan0 inet dhcp And still does'nt working.

lspci -knn | grep Net -A3

02:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a) 
    Subsystem: Intel Corporation Dual Band Wireless-AC 8260 [8086:0010] 
03:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265] [1002:6604] (rev ff) 
Kernel driver in use: radeon 

Please help me. Best regards.

  • Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. – Pilot6 Mar 21 '17 at 12:48
  • 1
    I added the command result on my question, thank you. – oai_network Mar 21 '17 at 12:56
1

You have an obsolete kernel that does not support this wireless adapter. You can upgrade your kernel to 4.4 and get the support.

Connect to the internet by wire or some other way and run

sudo apt-get install linux-lowlatency-lts-xenial

and reboot. This will upgrade your lowlatency kernel.

You may also need to install firmware for this adapter if it does not work. Post the output of dmesg | grep iwl if this is the case.

  • Thank you for answering my quetion, but the problem is that i am working on an application that require to install this kernel version. is an other soltion – oai_network Mar 21 '17 at 13:04
  • 1
    The 3.19 kernel does not support Intel 8260 wireless adapter. And what is the application that requires a specific kernel? If you need a lowlatency, the 4.4 will be a lowlatency as well. The 3.19 kernel is not supported any more. – Pilot6 Mar 21 '17 at 13:06
  • It's an application that need the real time kernel to run a network software code. – oai_network Mar 21 '17 at 13:08
  • 1
    So you will have a newer "real time kernel". – Pilot6 Mar 21 '17 at 13:09
  • Ok thank you a lot, My problem is that i don't have a adapted ethernet wire for my laptop to connect to internet and install the new kernel version. but because it's a unique solution, i will try to get it. thank you a lot. – oai_network Mar 21 '17 at 13:22
0

solved:

sudo apt-get install build-essential linux-headers-generic wget https://www.kernel.org/pub/linux/kernel/projects/backports/2015/12/18/backports-20151218.tar.gz

tar -zvxf backports-20151218.tar.gz

cd backports-20151218

make defconfig-iwlwifi

make

sudo make install

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.