2

I am struggling with my left mouse button. Sometimes my left mouse button stops working. It seems randomly. Sometimes after 5 minutes, sometimes everything is okay for 5 hours. Its NOT an hardware issue. I have tested external usb-mouse too, same issue appeard.

I can solve the problem by jumping to text-only console (CTRL-ALT-F1) and going back to graphical desktop.

But after some minutes our hours, same problem appears.

I have tried out different desktops and users too (Gnome, Mate and XFCE). In every desktop-environment, same issue appears.

The left button issue is different from time to time. Sometimes its like my left mouse button is clicked permanently, sometimes it doesnt react to whatever I do. Everything else works fine. (Right mouse button etc.).

I have already tried to solve my problem using google and stackExchange(i.e. this) but everything fixes my problem only for some minutes/hours.

I cant find a permanent solution. Thanks in advance.

Post where I am logging tries and possible solutions

3

I have exactly the same problem on a Sony Vaio with Xubuntu 16.04, but the left mouse button stops working about every third hour, both on the touchpad and on the external mouse. To date I have been logging out and in again to fix it. Recently I found this alternative.

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

Works fine for the external mouse, but the touchpad gets slow and stops scrolling. However, after entering the commands the hanging never bothers me, not even after a full workday.

0

I found a way to get round this by restaring lightdm .

sudo service lightdm restart

but it's not a fix solution , so each time you have this problem you have to type the command again , so to solve the problem once for all you have to changed lightdm to gdm

sudo apt-get install gdm
  • Rather drastic like selling the car when all you had to do was change the sparkplugs. – WinEunuuchs2Unix Mar 21 '17 at 12:20
  • Nope. I am already using gdm. – julandi Mar 21 '17 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.