4

I am struggling with my left mouse button. It stops working at random intervals -- sometimes after 5 minutes, other times everything is fine for 5 hours.

It's NOT a hardware issue. I have tested an external USB-mouse too, and the same issue occurred.

I can temporarily solve the problem by jumping to the text-only console (Ctrl+Alt+F1) and going back to graphical desktop. However, after some minutes or hours, the same problem returns.

I have tried different desktops and users too (Gnome, Mate and XFCE). In every desktop-environment, the same issue occurs.

The left button issue is different from time to time. Sometimes it's like my left mouse button is clicked permanently, sometimes it doesn't react to whatever I do. The right mouse button and cursor movement are never effected.

I have already tried to solve my problem using Google and StackExchange guidance (i.e. this), but the advice only ever delivers temporary fixes.

I am looking for a permanent solution.

Post where I am logging tries and possible solutions

2
  • Incredibly, I was getting this problem in 2005 if not earlier, and was working around it by switching to the text console CTRL+ALT+F1 every time. Fifteen years later, the same bug hits me on a Raspberry Pi.
    – automaciej
    Sep 20, 2020 at 9:10
  • I found a solution to my problem, I recently realized that every time my mouse stopped working correctly, my BlueTooth headset had connection problems. And the problem usually began after an unusual spike in CPU usage. After starting my PC, I once need to execute sudo systemctl start systemd-udevd systemd-udevd-kernel.socket systemd-udevd-control.socket && sudo systemctl start systemd-udevd systemd-udevd-kernel.socket systemd-udevd-control.socket I have no idea why that fixes the error for the whole session, I added it as a cronjob and its working fine since 6 months.
    – julandi
    Sep 21, 2020 at 18:07

2 Answers 2

5

I have exactly the same problem on a Sony Vaio with Xubuntu 16.04, but the left mouse button stops working about every third hour, both on the touchpad and on the external mouse. To date I have been logging out and in again to fix it. Recently I found this alternative.

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

Works fine for the external mouse, but the touchpad gets slow and stops scrolling. However, after entering the commands the hanging never bothers me, not even after a full workday.

1
  • I'm on Raspberry Pi 4, Raspbian GNU/Linux 10 (buster). External mouse. I'm getting the same symptoms are described above. When I try to remove the psmouse module, it turns out I didn't have it in the first place. $ sudo modprobe -r psmouse modprobe: FATAL: Module psmouse not found. So far the only workaround I found was switching to the text console with CTRL ALT F1 and back.
    – automaciej
    Sep 20, 2020 at 9:13
0

I found a way to get round this by restaring lightdm .

sudo service lightdm restart

but it's not a fix solution , so each time you have this problem you have to type the command again , so to solve the problem once for all you have to changed lightdm to gdm

sudo apt-get install gdm
2
  • Rather drastic like selling the car when all you had to do was change the sparkplugs. Mar 21, 2017 at 12:20
  • Nope. I am already using gdm.
    – julandi
    Mar 21, 2017 at 12:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .